This is a little confusing. Are you attempting to build a 0.17 project? If not, then I imagine you still have an old copy of
quasar-cliin the global npm or yarn namespace.
He was right. It is because you were using old version.
Uninstall quasar-cli if you have it from <1.0 versions
$ npm uninstall -g quasar-cli
Node.js >= 8.9.0 is required.
$ npm install -g @quasar/cli
Try with above commands.