Nice solution. I came across the same error using that package