I just found the answer here: https://github.com/quasarframework/quasar/issues/1616

“rwrz commented on 3 Sep •
For anyone appearing here, and is tired, and can’t find the reason, there are TWO plugin entries on quasar.conf.js, one for APP (where vuelidate should be) and one for BUILD (don’t put it here). Cya! 💯”