@FloatingPoint auth0-spa-js must run on a secure origin I think this specific library does not support Capacitor (SPA only). maybe this will help? https://github.com/moberwasserlechner/capacitor-oauth2 https://ionic.io/docs/auth-connect https://devdactic.com/capacitor-google-sign-in/ https://github.com/AyogoHealth/cordova-plugin-oauth