Quasar-cli installed using Yarn failing to upgrade



  • This error is similar to the error mentioned here: https://forum.quasar-framework.org/topic/5063/quasar-upgrade-is-failing-due-to-npm-server-error-on-mac . However, I installed quasar-cli using Yarn and the solution found in the topic is not working for me. Also, quasar info is oddly saying that NPM and Yarn are not installed.
    I am using Kubuntu 20.10

    cristiano@cristiano-note:~/workspace/teste-blah$ quasar upgrade
    
      Quasar CLI · Gathering information with yarn...
    
     @quasar/extras: 1.9.12 → Skipping!
       (⚠️  NPM server returned an error, so we cannot detect latest version)
     quasar: 1.14.7 → Skipping!
       (⚠️  NPM server returned an error, so we cannot detect latest version)
     @quasar/app: 2.1.13 → Skipping!
       (⚠️  NPM server returned an error, so we cannot detect latest version)
      Congrats! All Quasar packages are up to date.
    
    cristiano@cristiano-note:~/workspace/teste-blah$ quasar info
    
    Operating System - Linux(5.8.0-33-generic) - linux/x64
    NodeJs - 14.15.3
    
    Global packages
      NPM - 
      yarn - Not installed
      @quasar/cli - 1.1.3
      @quasar/icongenie - Not installed
      cordova - Not installed
    
    Important local packages
      quasar - 1.14.7 -- Build high-performance VueJS user interfaces (SPA, PWA, SSR, Mobile and Desktop) in record time
      @quasar/app - 2.1.13 -- Quasar Framework local CLI
      @quasar/extras - 1.9.12 -- Quasar Framework fonts, icons and animations
      eslint-plugin-quasar - Not installed
      vue - 2.6.12 -- Reactive, component-oriented view layer for modern web interfaces.
      vue-router - 3.2.0 -- Official router for Vue.js 2
      vuex - 3.6.0 -- state management for Vue.js
      electron - Not installed
      electron-packager - Not installed
      electron-builder - Not installed
      @babel/core - 7.12.10 -- Babel compiler core.
      webpack - 4.44.2 -- Packs CommonJs/AMD modules for the browser. Allows to split your codebase into multiple bundles, which can be loaded on demand. Support loaders to preprocess files, i.e. json, jsx, es7, css, less, ... and your custom stuff.
      webpack-dev-server - 3.11.0 -- Serves a webpack app. Updates the browser on changes.
      workbox-webpack-plugin - Not installed
      register-service-worker - 1.7.1 -- Script for registering service worker, with hooks
      typescript - 3.9.5 -- TypeScript is a language for application scale JavaScript development
      @capacitor/core - Not installed
      @capacitor/cli - Not installed
      @capacitor/android - Not installed
      @capacitor/ios - Not installed
    
    cristiano@cristiano-note:~/workspace/teste-blah$ yarn --version
    1.22.10
    cristiano@cristiano-note:~/workspace/teste-blah$ npm --version
    6.14.9
    cristiano@cristiano-note:~/workspace/teste-blah$ node --version
    v14.15.3
    

    My package.json:

    {
      "name": "teste-blah",
      "version": "0.0.1",
      "description": "A Quasar Framework app",
      "productName": "Quasar App",
      "author": "Cristiano <cristiano.moraes@gmail.com>",
      "private": true,
      "scripts": {
        "lint": "eslint --ext .js,.vue ./",
        "test": "echo \"No test specified\" && exit 0"
      },
      "dependencies": {
        "@quasar/extras": "^1.0.0",
        "core-js": "^3.6.5",
        "quasar": "^1.0.0"
      },
      "devDependencies": {
        "@quasar/app": "^2.0.0",
        "babel-eslint": "^10.0.1",
        "eslint": "^6.8.0",
        "eslint-config-standard": "^14.1.0",
        "eslint-loader": "^3.0.3",
        "eslint-plugin-import": "^2.14.0",
        "eslint-plugin-node": "^11.0.0",
        "eslint-plugin-promise": "^4.0.1",
        "eslint-plugin-standard": "^4.0.0",
        "eslint-plugin-vue": "^6.1.2"
      },
      "browserslist": [
        "last 10 Chrome versions",
        "last 10 Firefox versions",
        "last 4 Edge versions",
        "last 7 Safari versions",
        "last 8 Android versions",
        "last 8 ChromeAndroid versions",
        "last 8 FirefoxAndroid versions",
        "last 10 iOS versions",
        "last 5 Opera versions"
      ],
      "engines": {
        "node": ">= 10.18.1",
        "npm": ">= 6.13.4",
        "yarn": ">= 1.21.1"
      }
    }
    

    I tried to reinstall everything, create a new project, delete all node_modules folders. Nothing seems to work. I am running out of ideas. Any suggestions?

    Thanks
    Cristiano



  • @cristiano-moraes looks like your global dependencies are broken, try to uninstall and install, clear cache etc… also check on your nvm which npm version is actually being used, or if you’re not using nvm for npm then do so, also use node v12 for the mean time.



  • Hi @metalsadman. Thank you for your answer, I finally have this working.
    For the record, what I did was uninstalling everything (node/nvm/yarn) and respective caches and reinstalled everything again. But at this time I started by the nvm as suggested and swapped to node v12. I also, following another tip, installed quasar-cli using npm, once was said it is recommended using this for global packages.


Log in to reply