Hot reload or watch does not work



  • I investigated and

    1. Deleted node_modules and install it again
    2. fs.inotify.max_user_watches = 524288
    3. Try to sudo start quasar dev
    4. use – --reset-cache

    And all other suggestions I was able to find. But now I am desperate. I have no options left and it does not work.



  • @Serhioromano

    what’s the output of quasar info?



  • I run quasar in WSL2 on windows 10 pro.

    Operating System - Linux(4.19.128-microsoft-standard) - linux/x64
    NodeJs - 10.23.0
    
    Global packages
      NPM - 6.14.10
      yarn - Not installed
      @quasar/cli - 1.1.2
      cordova - 9.0.0 (cordova-lib@9.0.1)
    
    Important local packages
      quasar - 1.14.7 -- Build high-performance VueJS user interfaces (SPA, PWA, SSR, Mobile and Desktop) in record time
      @quasar/app - 1.9.6 -- Quasar Framework local CLI
      @quasar/extras - 1.9.12 -- Quasar Framework fonts, icons and animations
      eslint-plugin-quasar - Not installed
      vue - 2.6.11 -- Reactive, component-oriented view layer for modern web interfaces.
      vue-router - 3.2.0 -- Official router for Vue.js 2
      vuex - 3.6.0 -- state management for Vue.js
      electron - 7.3.3 -- Build cross platform desktop apps with JavaScript, HTML, and CSS
      electron-packager - 14.2.1 -- Customize and package your Electron app with OS-specific bundles (.app, .exe, etc.) via JS or CLI
      electron-builder - Not installed
      @capacitor/core - Not installed
      @capacitor/cli - Not installed
      @capacitor/android - Not installed
      @capacitor/ios - Not installed
      @babel/core - 7.12.3 -- Babel compiler core.
      webpack - 4.43.0 -- Packs CommonJs/AMD modules for the browser. Allows to split your codebase into multiple bundles, which can be loaded on demand. Support loaders to preprocess files, i.e. json, jsx, es7, css, less, ... and your custom stuff.
      webpack-dev-server - 3.11.0 -- Serves a webpack app. Updates the browser on changes.
      workbox-webpack-plugin - 4.3.1 -- A plugin for your Webpack build process, helping you generate a manifest of local files that workbox-sw should precache.
      register-service-worker - 1.7.1 -- Script for registering service worker, with hooks
      typescript - 3.8.3 -- TypeScript is a language for application scale JavaScript development
    
    Quasar App Extensions
      @quasar/quasar-app-extension-icon-genie - 1.1.3 -- A Quasar CLI Extension for Making All Your Icons
    
    Networking
      Host - HadesCanyon
      eth0 - 172.21.188.***
    


  • @Serhioromano

    Questio:n has hot reload ever worked for you in this setup / did it recently stopped working. Or has it never worked?

    I see you use WSL2 on windows.

    What if you run the same project on ‘just’ windows?



  • It used to work, but I did not work on my project for 6 month so I do not know when it stopped working. If I try it on windows it fails because I need to remove node_modules folder and run npm install again under windows to get appropriate binaries. May be if I do it, it will work, but then commands under WSL will stop working.

    This is how I fix this. I install another copy of Ubuntu as WSL 1 and run quasar from there. Now reload is working.


Log in to reply