Error when running npm run dev vs quasar dev (to use qenv)



  • @dobbel Sorry yes these are warning not errors.

    And yes I already did the test without these packages and still get these warnings when running npm run dev vs quasar dev. So I already ruled out these packages as the cause.



  • @GlutenBoy

    then you should keep removing…until the warning dissapears



  • ok but why don’t I see these warning when running quasar dev ?



  • @GlutenBoy

    I could guess: cross-env is injecting dependencies that are not compatible with quasar. Only way to know for sure is to create a new default quasar app with quasar cli and only add cross-env.



  • it’s not cross-env since I removed qenv and cross-env, put I will create a new app an insert all our extensions until I find the culprit. Although I’m not what will I do at this point… since we probably need that extension.



  • @GlutenBoy At this point, I’d scrub npm and use yarn. We keep telling people this. The reason is that npm has issues hoisting dependencies that bork the node_modules. And, yarn does a better job at it, but we have also seen issues (just not in the same quantity).

    Try to use yarn and report back to me as I would really like to know if that resolves your issue.



  • Hey @Hawkeye64 ,

    Actually I just did that, it didn’t resolve the problem, but after googling this even more, I found that on windows you get that error in the Powershell terminal but not in the good old cmd.exe terminal… so cmd.exe it is for now.

    Thx



  • @Hawkeye64 after more investigating, and cleaning everything up with yarn and using yarn in cmd.exe I now still getting the warning…

    The weird thing is that we never see these warning when running quasar dev.

    The only reason to use yarn run (or npm run) was to use qenv. Maybe I’ll skip that and build our own solution, and keep using ‘quasar dev’

    Maybe there’s a better way to debug these warning, but I didn’t found any solutions yet.



  • @GlutenBoy Hate to be poignant about it, but set up a VirtualBox with ubuntu. Put your sources over there and see if it works. I have a feeling it will. I used to be 100% windows guy (even worked for Microsoft twice, in the day), but because of issues for web dev, I have switch to 100% linux for the past few years.



  • @Hawkeye64 Yeah you’re right, I actually do have linux running on my workstation (dual boot), but I’m going to run a build on one of our pipeline in DevOps on ubuntu with the npm and see if I get the warnings.

    Mind you even though we get warnings, all seems to be working properly. It’s just bugging me and I don’t want this to come back to haunt us.

    Thx for your help!


Log in to reply