Problems with 1.14.5 Upgrade (Sass semicolons) and solution



  • I had some problems with the most recent upgrade - an error required me to delete the node_modules and .quasar folders and run npm install and quasar upgrade -i again.

    All good so far, but there was a compile error which I am writing about here because I am sure it will catch others out.

    The error was

    SassError: semicolons aren't allowed in the indented syntax.
    

    It turns out I had to remove the semicolons around my predefined colours in the quasar.variables.sass file.

    After that everything was back to normal.



  • Just so everyoine knows, we recently were using node-sass (a C++ node binder) which is now deprecated. Instead, we are now using sass (javascript). The sass version does better checking (linting) and therefore, if you have errors, these will show up.

    One thing I have noticed though, is if you are missing the colon (:) completely, you get a warning and it keeps on trucking (instead of failing), but it gives you a message about no descripter so won’t be used. For the line number it gives you, look up 1 higher for the issue.


Log in to reply