Visual Studio Code debug doesn't stop at breakpoints

  • it stop in vuejs file (vue), but if use mixin , exemplo <script>
    import notafiscal from ‘./notafiscal’

    export default {
    name: ‘PageIndex’,
    mixins: [notafiscal],
    doens’t stop in notafiscal.js breackpoints

  • Just to expand this topic a bit. I’ve been using Quasar for about 6 months on two different machines. Setting breakpoints has always been problematic. Typically, I can set breakpoints in pure .js files just fine, while breakpoints shown in any .vue file appears as “unbound breakpoint”. Then, magically, some day / build / version / phase of the moon I will hit a breakpoint in a .vue file giving me false hope, which is invariably dashed soon thereafter. Frustrating.

    Like the above, I too am using a mixin, hmm… Of course I can “quasar create” a new app which hits every breakpoint just fine.

    I’ve tried:

    • Updating webpack and all other related node_modules.
    • launch.json: Playing with dozens of variations of:
      “webRoot”: “${workspaceFolder}/ClientApp/src”,
      “sourceMaps”: true,
      “sourceMapPathOverrides”: {
      “webpack:///./src/": "${webRoot}/
    • Updating Chrome, VSCode, Debugger for Chrome
    • babel.config.js
      module.exports = {
      presets: [
    • quasar.conf.js
      build: {
      vueRouterMode: “history”, // available values: ‘hash’, ‘history’
      devtool: “source-map”, // tried lots of variations here!
      analyze: false, // jayb
      extendWebpack(cfg) {
      // cfg.plugins.push(new Analyzer.BundleAnalyzerPlugin()); // jayb added
      cfg.plugins.push(new WorkerPlugin()); // jayb added

    STOP THE PRESSES. I just tried commenting out “devtool” and “analyze” in quasar.conf.js (since a “quasar create” project doesn’t include these lines), and I’m hitting breakpoints again! Another moment of false hope? I’ll report back soon…

Log in to reply