[Solved] Error: "Could not find an installed version of Gradle"



  • I am using Quasar since 1 year.

    Yesterday I started working on a new project, for a android/ios app but using a new pc.
    I installed Android studio, quasar cli and tried to start the project and run in cordova mode

    I got this

    quasar dev -m android
    
     Converting to long form: -m cordova -T android
    
     Dev mode.......... cordova
     Pkg quasar........ v1.14.0
     Pkg @quasar/app... v1.9.6
     Debugging......... enabled
     Running mode...... cordova
    
     App · Reading quasar.conf.js
    ? What external IP should Quasar use? 192.168.20.43
     App · Checking listening address availability (192.168.20.43:3000)...
     App · Generating legacy js code (ES5); use "--modern" param for ES6+
     App · Extending Cordova Webpack config
     App · Generating Webpack entry point
     App · Booting up...
    
     • Compiling:
     └── Cordova ████████████████████ 100% done in 21483 ms
    
    
    
     DONE  Compiled successfully in 21490ms                                                                                                                                                               17:51:47
    i 「wds」: Project is running at http://192.168.20.43:3000/
    i 「wds」: webpack output is served from    
    i 「wds」: 404s will fallback to /index.html
     App · Updated Cordova config.xml   
     App · Running "cordova run android"
    
    No Java files found that extend CordovaActivity.
    
     App · Command "cordova" failed with exit code: 1
     App · Updated Cordova config.xml
     App · ⚠️  [FAIL] Cordova CLI has failed
    

    In this pc there is already android studio 4.

    I google around a bit but cannot find infos different than ‘install gradle manually’. I never needed to do this before.



  • Never mind… instructions are changed: https://quasar.dev/quasar-cli/developing-cordova-apps/preparation

    I must install manually gradle now.

    No problem.