CAPBridgeViewController.swift not found or content is unrecognized - Please disable HTTPS from quasar.conf.js > devServer > https

  • Can anyone help with the below error?

    Disabling HTTPS In quasar.conf hides the terminal error but I’m just stuck on the splashscreen (I think It’s loading scrips via https).


    Below works fine with PWA mode, and initially worked without any issues when running dev on IOS with capacitor. Quasar creates an external dev server when I run quasar dev -m capacitor -T ios which when I open, does not show any SSL errors.

    devServer: {
      https: {
        key: fs.readFileSync('ssl/server.key'),
        cert: fs.readFileSync('ssl/server.crt'),
      port: 8080,
      open: true // opens browser window automatically

    In Xcode, I get the following errors:

    ⚡️ WebView failed provisional navigation
    ⚡️ Error: The certificate for this server is invalid. You might be connecting to a server that is pretending to be “” which could put your confidential information at risk.

  • So In node_modules -> @quasar -> app -> lib -> capacitor -> capacitor-config.js, there Is a function called __handleSSLonIOS() that resolves the file “node_modules/@capacitor/ios/ios/Capacitor/Capacitor/CAPBridgeViewController.swift” however on @capacitor 2.4.0, the path Is “node_modules/@capacitor/ios/Capacitor/Capacitor/CAPBridgeViewController.swift”

    Current quasar version is 1.12.13


Log in to reply