q-input data binding dont work v1.12.10



  • Hi.

    After updating two versions, I noticed that the updating of the fields are not reflected in the inputs.
    Pkg quasar… v1.12.10
    Pkg @quasar/app… v1.9.6

    I have a watch where I validate with regular expressions if the field is correct, if not, it assigned the previous value, but this is not being reflected in the input.

    Watch:

    watch: {
        form: {
          deep: true,
          handler (newv, oldv) {
                if (this.form.username !== this.formBackup.username) {
                  this.form.username = this.$utils.validLastChar(this.form.username, this.$config.re.username.char)
                }
          }
        }
    }
    

    The funny thing is that the same thing happens to me in all the forms that used to work.

    Any idea?



  • Indeed, the versions after quasar … v1.9.16 -> 1.1x, have that problem.

    I tried a standard input and it worked.

    The same code that works in version 1.9.16, in version 1.x does not update the changes of the fields in the component (v-model).


Log in to reply