~~Do not upgrade to Vue 2.4.x (yet)~~ Edit: Safe to upgrade



  • Thanks @rstoenescu. v0.14.7 and Vue 2.5 fixes this. Just to inform after updating to Vue 2.5, I am getting other warning for QDataTable.

    (Emitted value instead of an instance of Error) the "scope" attribute for scoped slots have been deprecated
     and replaced by  "slot-scope" since 2.5. The new "slot-scope" attribute can also be used on plain elements
     in addition to <template> to denote scoped slots.
    

    This is fixed by changing scope to slot-scope as suggested. Not sure if examples at datatable needs to updated to reflect the same.

      <template slot="col-message" slot-scope="cell">
        <span class="light-paragraph">{{cell.data}}</span>
      </template>
    


  • @rv QDataTable is deprecated and replaced by QTable as of V0.15. The docs will be updated to reflect changes, including what you mentioned.



  • @benoitranque thanks for the info. Waiting for v01.5… 🙂


Log in to reply