TypeScript - VSCode doesn't recognize Quasar webpack aliases



  • I have the main project folder open, but the default webpack aliases that Quasar provides (components, boot, etc.) do not work. I had to manually add the aliases, which isn’t ideal.

    I have provided configuration files below. If there’s anything else you want to look at, let me know (like a specific portion of quasar.conf.js.

    .vscode/extensions.json

    {
      "recommendations": [
        "dbaeumer.vscode-eslint",
        "esbenp.prettier-vscode",
        "octref.vetur"
      ],
      "unwantedRecommendations": [
        "hookyqr.beautify",
        "dbaeumer.jshint",
        "ms-vscode.vscode-typescript-tslint-plugin"
      ]
    }
    

    .vscode/settings.json

    {
      "vetur.validation.template": false,
      "vetur.format.enable": false,
      "eslint.validate": ["javascript", "javascriptreact", "typescript", "vue"],
      "typescript.tsdk": "node_modules/typescript/lib",
      "vetur.experimental.templateInterpolationService": true
    }
    

    .tsconfig.json

    {
      "extends": "@quasar/app/tsconfig-preset",
      "compilerOptions": {
        "baseUrl": ".",
        "paths": {
          "router/*": ["./src/router/*"],
          "store/*": ["./src/store/*"],
          "types/*": ["./src/types/*"],
          "app/*": ["./*"],
          "src/*": ["./src/*"],
          "components/*": ["./src/components/*"],
          "layouts/*": ["./src/layouts/*"],
          "pages/*": ["./src/pages/*"],
          "assets/*": ["./src/assets/*"],
          "boot/*": ["./src/boot/*"]
        }
      }
    }
    

    VSCode global settings

    {
        "window.zoomLevel": 0,
        "files.trimTrailingWhitespace": true,
        "files.trimFinalNewlines": true,
        "workbench.colorTheme": "Oceanic Next (dimmed bg)",
        "java.home": "C:\\Program Files (x86)\\Java\\jdk1.8.0_112",
        "javascript.updateImportsOnFileMove.enabled": "always",
        "editor.formatOnPaste": true,
        "editor.formatOnSave": false,
        "editor.codeActionsOnSave": {
            "source.fixAll": true
        },
        "terminal.integrated.shell.windows": "C:\\WINDOWS\\System32\\WindowsPowerShell\\v1.0\\powershell.exe",
        "html.format.enable": false,
        "editor.showFoldingControls": "always",
        "editor.foldingStrategy": "indentation",
        "javascript.format.insertSpaceBeforeFunctionParenthesis": true,
        "javascript.format.placeOpenBraceOnNewLineForControlBlocks": false,
        "javascript.format.placeOpenBraceOnNewLineForFunctions": false,
        "javascript.format.insertSpaceAfterCommaDelimiter": false,
        "javascript.format.insertSpaceAfterFunctionKeywordForAnonymousFunctions": false,
        "javascript.format.insertSpaceAfterKeywordsInControlFlowStatements": false,
        "javascript.format.insertSpaceAfterOpeningAndBeforeClosingNonemptyBraces": false,
        "javascript.format.insertSpaceAfterSemicolonInForStatements": false,
        "javascript.format.insertSpaceBeforeAndAfterBinaryOperators": false,
        "git.enableSmartCommit": true,
        "powershell.codeFormatting.alignPropertyValuePairs": false,
        "editor.tabSize": 2,
        "aws.profile": "profile:default",
        "files.eol": "\n",
        "editor.suggestSelection": "first",
        "vsintellicode.modify.editor.suggestSelection": "automaticallyOverrodeDefaultValue",
        "files.exclude": {
            "**/.factorypath": true
        },
        "path-intellisense.showHiddenFiles": true,
        "java.configuration.checkProjectSettingsExclusions": false,
        "maven.executable.path": "Z:\\Programs\\Maven\\bin\\mvn",
        "editor.insertSpaces": false,
        "javascript.format.enable": false,
        "todo-tree.tree.showScanModeButton": false,
        "workbench.iconTheme": "material-icon-theme",
        "vetur.format.defaultFormatter.html": "js-beautify-html",
        "vetur.format.defaultFormatter.js": "vscode-typescript",
        "auto-rename-tag.activationOnLanguage": [
            "*"
        ],
        "splitHTMLAttributes.sortOrder": [
            "^v-if",
            "^v-else",
            "^v-show",
            "^v-model",
            "^v-for",
            "^:key",
            "^key",
            "^v-",
            "^:",
            "^@click",
            "^@",
            "^id",
            "^class",
            "^.*=\""
        ]
    }
    

Log in to reply