@quasar/app v1.8.9/10 released!


  • Admin

    https://github.com/quasarframework/quasar/releases/tag/%40quasar%2Fapp-v1.8.9

    • fix(app): use the htmlFilename as index for dev server in history mode #7078 (#7080)
    • fix(app): file executable rights for describe command


  • @rstoenescu I’m having issues installing the latest @quasar/app

    1. node --version ->
      10.16.3

    This is the latest stable version of node.

    1. quasar upgrade ->
      @quasar/app: 1.7.1 → 1.8.10

    2. quasar upgrade -I ->
      [1/5] 🔍 Validating package.json…
      [2/5] 🔍 Resolving packages…
      [3/5] 🚚 Fetching packages…
      error move-file@2.0.0: The engine “node” is incompatible with this module. Expected version “>=10.17”. Got “10.16.3”
      error Found incompatible module.
      info Visit https://yarnpkg.com/en/docs/cli/add for documentation about this command.

    Quasar CLI · ⚠️ Command “yarn” failed with exit code: 1

    1. Removed node_modules floder

    2. yarn install -> same error as above

    3. removed yarn.lock

    4. yarn install -> similar error as above with more @quasar/app related warnings

    yarn install v1.16.0
    info No lockfile found.
    [1/5] 🔍 Validating package.json…
    [2/5] 🔍 Resolving packages…
    warning @quasar/cli > metalsmith > gray-matter > coffee-script@1.12.7: CoffeeScript on NPM has moved to “coffeescript” (no hyphen)
    warning @quasar/app > webpack-dev-server > chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
    warning @quasar/app > webpack-dev-server > chokidar > fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
    warning @quasar/app > node-sass > request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
    warning @quasar/app > node-sass > node-gyp > request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
    warning @quasar/app > webpack > watchpack > watchpack-chokidar2 > chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
    warning @quasar/app > @quasar/babel-preset-app > @babel/runtime-corejs2 > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
    warning @quasar/app > fork-ts-checker-webpack-plugin > micromatch > snapdragon > source-map-resolve > resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
    warning @quasar/app > fork-ts-checker-webpack-plugin > micromatch > snapdragon > source-map-resolve > urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
    warning @quasar/app > stylus > css-parse > css > urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
    warning @quasar/app > @quasar/babel-preset-app > babel-plugin-transform-imports > babel-types > babel-runtime > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
    [3/5] 🚚 Fetching packages…
    error move-file@2.0.0: The engine “node” is incompatible with this module. Expected version “>=10.17”. Got “10.16.3”
    error Found incompatible module.
    info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

    Please advise, thanks.



  • @jeffatpf

    The engine “node” is incompatible with this module. Expected version “>=10.17”. Got “10.16.3”

    You are using Node v10.16.3, you need to upgrade to at least v10.17.0 as stated in the error message. Currently, the latest v10.x version is v10.20.1, so I would suggest upgrading your Node to v10.20.1 or v12.x.



  • @yusufkandemir Strange, I use NVM and the latest “stable” version shows as 10.17.0. Updated to 10.20.1 and all is good. Thank you.


Log in to reply