vueCompiler: true does not seem to include Vue runtime + compiler



  • Hello,

    I am trying to use v-runtime-template (https://github.com/alexjoverm/v-runtime-template) or any other way of using Vue templates that are not pre-compiled. I have activated the option in quasar.conf.js:

    build: {
      vueCompiler: true
    }
    

    That seems like the only necessary step to bundle both Vue runtime + compiler, but it does not seem to work. For instance, see https://quasar.dev/quasar-cli/quasar-conf-js#Property%3A-build and https://github.com/alexjoverm/v-runtime-template/issues/16.

    When I try to run the code with quasar dev, I get the error:

    [Vue warn]: You are using the runtime-only build of Vue where the template compiler is not available. Either pre-compile the templates into render functions, or use the compiler-included build.
    

    I don’t think the problem is related to v-runtime-template as the message is the generic Vue error for the case when the compiler is not present.

    I have upgraded to the latest Quasar version of everything but the problem persists.

    Is there anything else I should be doing? Thank you in advance!



  • I have tried creating a Quasar project from scratch and using the demo project, install v-runtime-template and try a trivial example. That works, so the problem seems to be related with my particular project. I have tried removing both the node_modules directory and the package-lock.json file and run npm install but it does not help. Any ideas will be appreciated. Thank you!



  • Finally I have used a quasar.conf.js from a new blank project generated with the latest CLI and moved all specifics from the former conf to the new one. Both conf files are different and I am not sure what has done it. But now the compiler option works. Seems like using a conf file from an old Quasar version (mine probably started with v0.17) breaks something with newer Quasar versions.