Capacitor build do not work anymore with iOS



  • Hi,

    I’ve never have been an issue with capacitor since I use it (I cannot say that for cordova which was breaking something every release…), but now I have this problem:

    NSForwarding: warning: object 0x1d64f3b70 of class 'PFEmbeddedMulticasterImplementation' does not implement methodSignatureForSelector: -- trouble ahead
    NSForwarding: warning: object 0x1d64f3b70 of class 'PFEmbeddedMulticasterImplementation' does not implement doesNotRecognizeSelector: -- abort
    

    It seems the exact same case as here:
    https://github.com/ionic-team/capacitor/pull/2414

    Do you know how I could change the inner version that quasar cli uses when building for capacitor?

    Is there a way to get the latest version of capacitor (2.^) instead of 1.4^?

    Anyone develop for iOS with Capacitor here, did you have this issue too?

    Thanks



  • Ok I found the problem, quasar upgrade -i does not upgrade capacitor related packages.
    For those interested by the solution:
    I started a brand new project with quasar create, added capacitor and built for ios, it worked, so I compared the package.json and updated mine then ran yarn install in the src-capacitor.

    However I’m wondering why it’s still using ^1.0.0 for @capacitor/core and capacitor/cli ?
    It’s now set in ^2.0.2 for @capacitor/android and @capacitor/ios but not /core and /cli.



  • @AVISYNC please issue a ticket for this at quasar’s gh repo.


Log in to reply