@quasar/app v1.8.0/3 released! Major improvements.


  • Admin

    https://github.com/quasarframework/quasar/releases/tag/%40quasar%2Fapp-v1.8.0

    Small behavior change

    New

    • feat(app): perf improvements for the PWA and SSR+PWA mode; your PWA will now be accessible offline even if starting browser with a non-root path of your app
    • feat(app): Improved the build progress bar
    • feat(app): Enhance the “quasar new” command; it can now generate TS assets too #6886
    • feat(app): include nodeIntegrationInWorker for Electron in template

    Fixes

    • fix(bex): add TS support to BEX mode #6883 #6887


  • @rstoenescu Getting error after upgrading

    quasar build -m pwa
    
    
     Build mode........ pwa
     Pkg quasar........ v1.10.0
     Pkg @quasar/app... v1.8.0
     Debugging......... no
     Publishing........ no
    
     app:extension Running "@quasar/qcalendar" Quasar App Extension... +0ms
     app:quasar-conf Reading quasar.conf.js +11ms
     app:quasar-conf Extension(@quasar/qcalendar): Extending quasar.conf... +5ms
     App Extension (qcalendar) Info: 'Adding qcalendar boot reference to your quasar.conf.js'
     App Extension (qcalendar) Info: 'Adding calendar-daily.styl css reference to your quasar.conf.js'
     App Extension (qcalendar) Info: 'Adding calendar-weekly.styl css reference to your quasar.conf.js'
     app:workbox [InjectManifest] Using your custom service-worker written file +1s
     app:webpack Extending PWA Webpack config +41ms
     app:artifacts Cleaned build artifact: "/Applications/MAMP/htdocs/lumen/school_front/school_app/dist/pwa" +12ms
     app:generator Generating Webpack entry point +0ms
     app:build Building... +9ms
    
     • Compiling:
     └── PWA ████████████████████ 95% emitting manifest.json
    
    (node:5572) UnhandledPromiseRejectionWarning:   ValidationError: "runtimeCaching" is not a supported parameter.
    

  • Admin

    Clean the yarn.lock / node_modules. Prolly a miss on yarn/npm.
    The workbox version has not changed at all.


  • Admin

    @jitendra16 Ok, I see what you mean. There was a problem in quasar/app. Released v1.8.2 which fixes it.



  • @rstoenescu Thank you. Build is successful now.



  • @rstoenescu after upgrade i am having one issue of HMR, now home path (’/’) is loaded every time when I save changes in other path. This is irritating in development/debugging. If I clear cache then this problem doesn’t occurs. But now I need to clear browser cache every time before ‘quasar run dev’ .



  • This post is deleted!

  • Admin

    @jitendra16 If you’re using PWA, then it’s normal. Please read how to correctly do it https://quasar.dev/quasar-cli/developing-pwa/hmr-for-dev



  • I also recently have had HMR problems (browser not releasing cache/updating) developing in PWA mode, which I never had until recent updates, so it seems like something has changed in the code base. In any event, I followed the instructions above and have set devtools to ignore SW and this seems to work for now.


  • Admin

    @ssuess Quasar App CLI was tampering too much with the workbox config. It’s much better to keep App CLI interfering as little as possible (like now), which is what it has been done. Hence the new docs page on how to handle HMR when on a PWA. It may “feel” harder to use, but at the end of the day it’s just about clicking a checkbox in chrome/ff devtools 🙂 The benefits heavily outweight this downside.



  • @rstoenescu Thanks for the response, and I understand your motivations. But in practice, after using it for several days in the recommended way, I find this a much worse development experience. Perhaps I am doing something wrong, but even after checking the box to disable caching/bypass for network, I very often have to force reload (shift + reload) after hmr has refreshed the page in the browser to see my changes. And often more than once. It seems that my browsers (latest chromium based edge and firefox on mac os) are having problems displaying the updated code changes. Any other suggestions for getting this to work as it did before? Thanks for any advice.


  • Admin

    @ssuess Assuming that you are using GenerateSW, you’d need this worboxOptions:

    chunks: [ 'some-bogus-chunk' ],
    runtimeCaching: [
      { urlPattern: '/', handler: 'NetworkFirst' },
      { urlPattern: /^http/, handler: 'NetworkFirst' }
    ]
    

    Remember to only apply this for dev mode. In quasar.conf.js: workboxOptions: ctx.dev ? optionsAbove : {}
    But I recommend just using Google Chrome instead of above.


Log in to reply