Built Electron app shows nothing: "Not allowed to load local resource"



  • I have played around with Quasar Electron by creating a brand new app and building it without any modification by electron-packager. Though opening .exe built file showed nothing. I saw an error in the console: Not allowed to load local resource: ...\resources\app.asar/index.html.
    I use Quasar@1.7.2. The target platform is win32.
    Does anyone get the same?



  • I got the same error on mac, also cordova and capacitor loads the app but when i navigate to some routes such as /about I got a 404 error saying /about/app.js wasn’t found



  • @bonniss did you find a solution to it? I’ve got the same problem



  • Haven’t seen this for a while as I chose pure Electron for my project. Just make a fresh test and it seems that the issue was solved.

    My package.json

    "dependencies": {
        "@quasar/extras": "^1.0.0",
        "core-js": "^3.6.5",
        "quasar": "^1.0.0"
      },
      "devDependencies": {
        "@quasar/app": "^2.0.0",
        "babel-eslint": "^10.0.1",
        "devtron": "^1.4.0",
        "electron": "^9.0.0",
        "electron-debug": "^3.0.1",
        "electron-devtools-installer": "^3.0.0",
        "electron-packager": "^14.1.1",
        "eslint": "^6.8.0",
        "eslint-config-standard": "^14.1.0",
        "eslint-loader": "^3.0.3",
        "eslint-plugin-import": "^2.14.0",
        "eslint-plugin-node": "^11.0.0",
        "eslint-plugin-promise": "^4.0.1",
        "eslint-plugin-standard": "^4.0.0",
        "eslint-plugin-vue": "^6.1.2"
      }
    

Log in to reply