[solved (non issue)] Q-Popup-Edit spacebar is closing it?



  • Admittedly, I’m on an older version of 1.0 (1.1.4 actually), so this may be fixed. I haven’t been able to update to a newer version because my code base is huge and haven’t had the time necessary for an upgrade. I will soon, however.

    Anyway, I have some popup edits setup on a table. It all works as expected except that typing a space will close the popup. The space is added, but when I have a string with multiple spaces, it requires me to click the field to edit it several times.

    Here is my code. This sits inside a <td>. The first part of the v-if shows several buttons in the first column. The rest of the columns (which contain the actual data) shares the following:

    <span
                  v-else
                  :class="mousePointer(props.row.new, col.name)"
                >
                  {{ props.row[col.field] !== '' ? props.row[col.field] : 'null' }}
                  <q-popup-edit v-model="props.row[col.name]" v-if="props.row.new !== null && editAllowed(col.name)" @save="saveChange(props.row)">
                    <template v-slot="{ initialValue, value, emitValue, validate, set, cancel }">
                      <q-input v-model="props.row[col.name]" dense autofocus counter>
                        <template v-slot:prepend>
                          <q-icon name="edit" />
                        </template>
                        <template v-slot:after>
                          <q-btn flat dense color="negative" icon="cancel" @click.stop="cancel" />
                          <q-btn flat dense color="positive" icon="check_circle" @click.stop="set" />
                        </template>
                      </q-input>
                    </template>
                  </q-popup-edit>
                </span>
    

    Is this a known issue? Is there a work around, or has this been fixed in a newer version of Quasar?



  • This isn’t a known issue AFAIK. Hard to tell what the cause is from that small slice of code. Can you reproduce in a codepen or codesandbox?

    Scott



  • Thanks. This is weird. I commented out some code, compiled, uncommented, compiled, and then it just worked. Perhaps I should be deleting the contents of the dist folder each time? Could something not have been compiled correctly?



  • I have no idea and also have not heard of such a thing before. But, computers are computers and anything is possible. 🙂

    Scott


Log in to reply