quasar-logo.svg doesn't display on cordova after clean

  • Hello,
    I ran

    cordova clean

    in the src-cordova folder and now when I run the cordova build, the logo won’t display although there is no problem with the SPA:

    quasar dev

    shows me the logo.
    What have I done wrong? Why can’t my app fetch https://cdn.quasar.dev/logo/svg/quasar-logo.svg anymore?

    Thanks 🙂

  • Admin

    It’s best not to use external links when writing a Cordova app, otherwise your users will also be dependant on an Internet connection.

    However should you still want to pursue this path, check the remote debugger and see what the problem is: https://quasar.dev/quasar-cli/developing-cordova-apps/troubleshooting-and-tips#Android-remote-debugging or https://quasar.dev/quasar-cli/developing-capacitor-apps/troubleshooting-and-tips#iOS-remote-debugging
    You probably need some permissions added in /src-cordova/config.xml ?

  • Actually this external link was already set by Quasar, and at first it worked. What is strange is that I didn’t change anything in the config.xml:

    <?xml version='1.0' encoding='utf-8'?>
    <widget id="fr.nc.delegue.referendum" version="0.0.1" xmlns="http://www.w3.org/ns/widgets" xmlns:cdv="http://cordova.apache.org/ns/1.0">
        <author email="dev@cordova.apache.org" href="http://cordova.io">
            Apache Cordova Team
        <content src="index.html" />
        <plugin name="cordova-plugin-whitelist" spec="1" />
        <access origin="*" />
        <allow-intent href="http://*/*" />
        <allow-intent href="https://*/*" />
        <allow-intent href="tel:*" />
        <allow-intent href="sms:*" />
        <allow-intent href="mailto:*" />
        <allow-intent href="geo:*" />
        <platform name="android">
            <allow-intent href="market:*" />
        <platform name="ios">
            <allow-intent href="itms:*" />
            <allow-intent href="itms-apps:*" />
        <allow-navigation href="about:*" />

Log in to reply