QPdfViewer, VUE CLI



  • I would like to integrate QPdfViewer into a web app that we build using the vue cli and not the quasar cli; I can’t change that at the moment.

    In the package.json I have this:
    “dependencies”: {
    “@quasar/extras”: “^1.0.0”,
    “@quasar/quasar-app-extension-qpdfviewer”: “^1.0.0-beta.5”,

    “devDependencies”: {
    “@quasar/quasar-app-extension-qpdfviewer”: “file:…/.”

    I get this error: Unknown custom element: <q-pdfviewer>

    I understand that I have to register the component but I have no idea how to do that.

    Thanks

    Quasar is great, the new V1 stuff is exiting.



  • Quasar app extensions is only available on quasar cli app afaik.



  • Thanks for the response.
    I was able to use the excellent QCalender extension, got that to work fine using the Vue CLI.
    I know that the right answer is to use the quasar cli, but if anybody can point me some hints on how it could be done, I would greatly appreciate it.



  • QPdfviewer has not been converted yet to use with Vue CLI
    @Theo



  • @Hawkeye64
    Ok, understand,
    thanks


Log in to reply