Build error with quasar.variables.scss in Quasar 1.6.1



  • Hi everyone !

    I upgraded my project from 0.17 to 1.x 2 months ago and i didn’t have any main issues until today…

    Referring to the documentation, I removed the quasar.variables.styl and replaced it by quasar.variables.scss and of course adapted the stylus to scss.

    Now I just have the quasar.variables.scss in the css folder but when I try to compile I get an error :

    error  in ./node_modules/quasar/dist/quasar.sass
    node_1  |
    node_1  | Module build failed (from ./node_modules/sass-loader/lib/loader.js):
    node_1  |
    node_1  | /*!
    node_1  | ^
    node_1  |       File to import not found or unreadable: quasar/src/css/variables.sass.
    node_1  |       in /var/www/node_modules/quasar/dist/quasar.sass (line 1, column 1)
    node_1  |
    node_1  |  @ ./node_modules/quasar/dist/quasar.sass 4:14-251 14:3-18:5 15:22-259
    node_1  |  @ ./.quasar/client-entry.js
    node_1  |  @ multi (webpack)-dev-server/client?http://0.0.0.0:80 (webpack)/hot/dev-server.js ./.quasar/client-entry.js
    

    If I put back the quasar.variables.styl with the quasar.variables.scss the error is not here anymore but the css from the quasar.variables.scss is not even read (normal referring to the doc).

    Do you have any idea why I can’t just have the quasar.variables.scss ?

    Thanks in advance ! 🙂



  • It worked for me when I upgraded, just like you did it. I replaced the .styl file with the .scss variant.

    On the doc page you linked, there is a warning that says:

    When creating or deleting any of the src/css/quasar.variables.* files, you will need to restart your devserver in order for it to take effect

    Maybe you missed that?
    But then again, you said it worked before… idk, just an idea.

    Another idea, but not sure if it helps, but I would try stopping the devserver, then run quasar clean and then try again



  • @chyde90 thank you for your help but it does not work…
    I tried quasar clean and I already restarted multiple times the devserver before that try…

    Any other idea ?



  • By the way I’m using Docker too.
    Do you think it could be related to docker ?



  • No idea ? 😕


Log in to reply