@quasar/app v1.4.1 released! Includes security update


  • Admin

    Enjoy!

    https://github.com/quasarframework/quasar/releases/tag/%40quasar%2Fapp-v1.4.1

    Security

    • Upgraded deps: compression-webpack-plugin@3.0.1, copy-webpack-plugin@5.1.1, css-loader@3.3.2, terser-webpack-plugin@2.3.0, vue-server-renderer@2.6.11

    New

    • feat(app): Use vendor chunk for dev too (reduces duplication of vendor code)
    • Other upgraded deps: vue@2.6.11, vue-template-compiler@2.6.11, webpack-chain@6.1.0

    Fixes

    • fix(app): correctly fill in auto import statements for TS


  • I’m getting the following error after upgrading and running:

    Vue packages version mismatch:

    • vue@2.6.10 (C:…\node_modules\vue\dist\vue.runtime.common.js)
    • vue-template-compiler@2.6.11 (C:…\node_modules\vue-template-compiler\package.json)

    This may cause things to work incorrectly. Make sure to use the same version for both.
    If you are using vue-loader@>=10.0, simply update vue-template-compiler.
    If you are using vue-loader@<10.0 or vueify, re-installing vue-loader/vueify should bump vue-template-compiler to the latest.

    I’ve tried upgrading vue-template-compiler, but nothing happened.



  • I did it like this
    catalog of the project > npm install vue
    or -g ??
    !! Probably wrong, but it works.
    install vue@2.6.11



  • @ArkIv npm install vue worked for me, thanks!



  • I got the same issue as you @gruppler and npm install vue didn’t fix it for me but npm install vue-template-compiler.


  • Admin

    Do not manually install vue and vue-template-compiler. These come out of the box with “@quasar/app”.


Log in to reply