Cordova generated app missing Modules variables

  • Hello,

    I’m developing simple application for Android using Quasar. It’s working fine in Quasar Play and in Development mode, but when exporting it with Cordova, it shows UI, but won’t render things coming from variables - like mustache templates or v-show divs. Anyone knows what is up? I don’t really know how to debug Cordova, and when I used Ionic a while ago, it worked well. I didn’t find anything related in documentation unfortunately. Any help is welcome!

  • Admin


    Might be a case of something misused. Do you have a repo I can take a look? Code talks more than plain words 🙂

  • Unfortunately it’s hosted on private GitLab. I would have to make you account to browse through the code 😃 I can do this or tell me which files should I share, there is not a lot of code as I’m really unexperienced with Quasar, Vue and JS hybrid apps in general.

  • Admin

    Add me to the repo. I take a look, see what’s wrong, then you can remove me. I’m only interested in finding if there’s an issue or not. My id is rstoenescu.

  • Okay, so I have figured it out. I added functions to data, not methods. Moving them to methods worked. I’m sorry, it’s my Vue incompetence that got in the way. 🙂

  • Admin

    I’m glad you figured things out. Was about to contact you so I can take a look now, but you were faster 🙂

Log in to reply