app:dev-server ⚠️ Failed to open default browser



  • Compiled successfully in 9873ms

    App dir........... c:/proj
    App URL........... http://localhost:8080
    Dev mode.......... spa
    Pkg quasar........ v1.4.1
    Pkg @quasar/app... v1.2.3
    

    i 「wds」: Project is running at http://0.0.0.0:8080/
    i 「wds」: webpack output is served from
    i 「wds」: 404s will fallback to /index.html
    app:dev-server Opening default browser at http://localhost:8080 +10s

    app:dev-server ⚠️ Failed to open default browser +4ms

    Hi,
    I tried to reinstall npm and cli with no success.
    Any ideas?



  • @infoPANEL pls post your quasar info logs.



  • Hi, find below my: quasar info

    Operating System - Windows_NT(10.0.17763) - win32/x64
    NodeJs - 12.13.0

    Global packages
    NPM - 6.12.0
    yarn - Not installed
    @quasar/cli - 1.0.2
    cordova - Not installed

    Important local packages
    quasar - 1.4.3 – Build high-performance VueJS user interfaces (SPA, PWA, SSR, Mobile and Desktop) in record time
    @quasar/app - 1.2.3 – Quasar Framework local CLI
    @quasar/extras - 1.3.3 – Quasar Framework fonts, icons and animations
    vue - 2.6.10 – Reactive, component-oriented view layer for modern web interfaces.
    vue-router - 3.1.3 – Official router for Vue.js 2
    vuex - 3.1.1 – state management for Vue.js
    electron - Not installed
    electron-packager - Not installed
    electron-builder - Not installed
    @capacitor/core - Not installed
    @capacitor/cli - Not installed
    @capacitor/android - Not installed
    @capacitor/ios - Not installed
    @babel/core - 7.7.2 – Babel compiler core.
    webpack - 4.41.2 – Packs CommonJs/AMD modules for the browser. Allows to split your codebase into multiple bundles, which can be loaded on demand. Support loaders to preprocess files, i.e. json, jsx, es7, css, less, … and your custom stuff.
    webpack-dev-server - 3.9.0 – Serves a webpack app. Updates the browser on changes.
    workbox-webpack-plugin - 4.3.1 – A plugin for your Webpack build process, helping you generate a manifest of local files that workbox-sw should precache.
    register-service-worker - 1.6.2 – Script for registering service worker, with hooks

    Quasar App Extensions
    None installed

    I run “quasar create testApp” with minimal options. The browser won’t open even if I change options.
    I also reinstalled webpack - no success.
    Any hint will be highly appreciated.



  • Same problem here. Have not used the framework for a while. I setup a fresh clean project, and the browser never opens - even though open: true is set.



  • I’ve observed the same as others when creating a new project. (using same version of NodeJS). On Windows 10 we get the following error dialog:

    Windows cannot find \‘http://localhost:8080\’. Make sure you’ve typed the name correctly, then try again

    Screenshot: https://imgur.com/a/MEHaZEi

    Looks like the issue might be escaping slashes.

    FWIW this error is not observed if we configure https: true.

    Open in browser worked fine in earlier versions of Quasar CLI.





  • Hmm just checked my older project running quasar 1.4.3, @quasar/app@1.2.4 and @quasar/cli@1.0.0. I get the failed to open in default browser. This was working… Only thing that’s changed is Windows 10 just installed a bunch of updates (this is on a different/less used machine). Perhaps it’s Windows that’s breaking the behaviour.

    Since it’s broken, I upgraded this older project to @quasar/cli@1.0.3, quasar 1.5.9 and @quasar/app@1.4.1 and I’m still seeing the failed to open in default browser.



  • Hi,
    this is still an issue with quasar dev in WSL. I don’t think it’s an issue with windows 10 since VUE projects are opened without issues with npm run serve. And that is able to open the browser.

    $quasar info

    Operating System - Linux(4.4.0-18362-Microsoft) - linux/x64 NodeJs - 10.18.1 Global packages NPM - 6.13.6 yarn - Not installed @quasar/cli - 1.0.5 cordova - Not installed Important local packages quasar - 1.7.1 – Build high-performance VueJS user interfaces (SPA, PWA, SSR, Mobile and Desktop) in record time @quasar/app - 1.5.0 – Quasar Framework local CLI @quasar/extras - 1.4.0 – Quasar Framework fonts, icons and animations vue - 2.6.11 – Reactive, component-oriented view layer for modern web interfaces. vue-router - 3.1.3 – Official router for Vue.js 2 vuex - 3.1.2 – state management for Vue.js electron - Not installed electron-packager - Not installed electron-builder - Not installed @capacitor/core - Not installed @capacitor/cli - Not installed @capacitor/android - Not installed @capacitor/ios - Not installed @babel/core - 7.8.3 – Babel compiler core. webpack - 4.41.5 – Packs CommonJs/AMD modules for the browser. Allows to split your codebase into multiple bundles, which can be loaded on demand. Support loaders to preprocess files, i.e. json, jsx, es7, css, less, … and your custom stuff. webpack-dev-server - 3.10.1 – Serves a webpack app. Updates the browser on changes. workbox-webpack-plugin - 4.3.1 – A plugin for your Webpack build process, helping you generate a manifest of local files that workbox-sw should precache. register-service-worker - 1.6.2 – Script for registering service worker, with hooks Quasar App Extensions None installed


Log in to reply