Wrong Quasar version reported during runtime?



  • Is there a reason why this.$q.version always reports 1.1.0 at runtime? The relevant part of my package.json is:

    "dependencies": {
        "@quasar/extras": "^1.0.0",
        "core-js": "^2.6.5",
        "quasar": "^1.2.7",
        "vue": "^2.6.10",
        "vue-router": "^3.1.3"
      },
    

    and my function:

    showVersions: function(vue)
      {
        this.notify(vue,
          `Vue version: ${Vue.version}\n` +
          `Quasar version: ${vue.$q.version}\n` +
          `Environment: ${process.env.NODE_ENV}`
        );
      },
    

    which is called like showVersions(this).

    I believe it should report 1.2.7 instead. Thanks in advance!



  • Note to admins: I’m not sure I’ve posted this in the right forum, please feel free to move it around if need.



  • Please provide more info, you didnt specify where are you using your showversion function.



  • To @metalsadman:

    Okay, I’ve put together a very simple pen that shows the Quasar version is being displayed correctly when calling this.$q.version. So it seems my problem is elsewhere, but to me it just doesn’t make sense. The report from my latest npm update quasar command is:

    npm WARN sass-loader@8.0.0 requires a peer of sass@^1.3.0 but none is installed. You must install peer dependencies yourself.
    npm WARN sass-loader@8.0.0 requires a peer of fibers@>= 3.1.0 but none is installed. You must install peer dependencies yourself.
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules\fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
    
    + quasar@1.2.7
    updated 1 package and audited 24969 packages in 8.329s
    found 0 vulnerabilities
    

    As you can see, apparently I’ve upgraded to 1.2.7.

    package.json also confirms my version to be 1.2.7 as you can see in the first post. But in my app, this.$q.version still reports 1.1.0 no matter what.



  • Post your quasar info log



  • @metalsadman said in Wrong Quasar version reported during runtime?:

    Post your quasar info log

    Here:

    Running @quasar/cli v1.0.0

    and

    Operating System                Windows_NT(10.0.18362) - win32/x64
    NodeJs                          10.15.3
    
    Global packages
      NPM                           6.4.1
      yarn                          Not installed
      @quasar/cli                   1.0.0
      cordova                       Not installed
    
    Networking
      Host                          Rubem-Desktop
      Ethernet                      192.168.0.14
      vEthernet (Default Switch)    192.168.214.177
    

    I assume there should be more info, but that’s all there is.



  • Its suggested to use yarn in quasar, cd your project, delete node_modules folder and package-lock.json, install yarn, run yarn, run quasar upgrade -i. Just noticed the command you ran, its not npm update quasar but use quasar cli’s quasar upgrade -i.



  • Ok, thanks! Will do.


Log in to reply