quasar project not run after build

  • hi ,
    recently i am facing a problem with run build copy after updating the quasar cli to v0.6.1. my previous build copy run smoothly with same code. my quasar version is v0.13.6 . can you plz tell me what should i do

  • It’s hard to help you with just this information. Can you provide any errors you are getting or what you are seeing? To fix your problem, you probably need to refactor your code to fit version 13, which btw, is at v0.13.9.

    But, before you waste time on that, v0.14 is coming out soon, and you’ll probably want to refactor to that version, as it is the future of Quasar and quite different than 0.13.9.

    Until then, my best bet is, you’ll need to stick to v0.6.1.


  • @s.molinari actually i didn’t get any error. the problem is after build my project when i serve the files from dist folder to my apache server its not run. the project is run in dev mode. the only thing i done is update the quasar cli to 0.6.1 from v0.5 something. and my quasar version is 0.13.6 .

    is there any version conflict happened? koz before update the cli the previous build copy run well. or i have to updated the quasar v0.13.6 to v0.13.9 .

    i am in trouble because i have show my project by today to my client. plz help.

  • Admin

    @Sujan-Dev Upgrading the CLI shouldn’t break anything. The build process is defined by the starter kit that you are using (see /build folder in your project’s folder). You say that you build and then serve the dist folder from an apache server and it doesn’t works. If it worked before upgrading the CLI, it should work just the same after upgrading it. Nothing changed regarding build. The problem is elsewhere. I am a little confused as you then say “the project is run in dev mode”. Are you serving the distributable (/dist) or are you running the development server? In both situations, upgrading CLI won’t break anything. It may be your apache at fault. Have you tried with quasar serve command after making a build? It does an ad-hoc web server pointed to your distributable – so basically same thing as apache.

Log in to reply