ios build command not working - invalid simulator syntax maybe?

  • Hello,

    if I run “quasar dev -m cordova -T ios -e iPhone-X,”, then I get an error that says

    “xcodebuild: error: Unable to find a destination matching the provided destination specifier:
    { platform:iOS Simulator, OS:latest, name:iPhone X }
    The requested device could not be found because no available devices matched the request.”

    Note that iOS 13 is the latest, not 12.2, which is what I specified. So for some reason, it ignored that part of what was passed in. Also note that I do have 12.2 installed and quite a lot of devices are available for 12.2.

    It then lists a bunch of possible simulators in the same curly brace syntax, including the one I specified.

    Alternatively, if I run “quasar dev -m cordova -T ios” it selects the latest iPhone model and latest OS version. This works just fine. Also, I seem to be able to specify any device so long as it used the latest OS. I just can’t use an older OS.

    If I try other methods, like using the UUID as presented in the list I’m shown, it gets pretty far in the build and only fails at the simulator startup.

    Like this: “quasar dev -m cordova -T ios -e 321C3176-2AFC-4333-8763-A810611F10EC”

    Generates this error: “Error: Unhandled error. (’[ios-sim] Device type “” could not be found.\n’)”

    Notice, that it expects to put whatever is passed into the -e parameter on the end of “”, but that doesn’t seem to work.

    It seems like a change was made and now not all of the modules in the chain understand each other.

    Has anyone seen this? Any idea which module is at fault so I could open a bug report there? ios-sim, maybe?

  • Note that I think I was also able to get to the same point where just ios-sim was failing if I passed in something like this in the -e parameter:

    { platform:iOS Simulator, id:321C3176-2AFC-4333-8763-A810611F10EC, OS:12.2, name:iPhone 7 }

    Once again, this just got added to the end of the “” string, so of course it didn’t work.

  • Nobody else building/testing for various older iOS devices?

  • I’m having the same issue, but I can’t even get the “quasar dev -m cordova -T ios” to work. Really frustrating. I upgraded quasar hoping the tooling might have been out of date, but no luck. I can’t run my app in any iOS now, SPA and Android work fine … sigh.

Log in to reply