Windows 10 won't read quasar-cli

  • node -v : 7.2.1 (via nodist)
    npm -v: 3.10.10

    Have tried both npm install -g quasar-cli & npm install quasar-cli -
    Getting the standard… C:...\Projects\MobileApps\Quasar>quasar init [name of folder] 'quasar' is not recognized as an internal or external command, operable program or batch file.…error

    What to do? What to do?
    Am using ndm for global npm version checks and it registers the quasar-cli at version 0.6.1

  • Usually this means you are missing a path entry to access the globally installed packages. Make sure you have properly installed node (like as an administrator) and also make sure there is a path entry in your user variables. Something like C:\Users\yourname\AppData\Roaming\npm.


  • @s.molinari
    Am using Nodist for version controls (node & npm)
    package.json requires node v 4.2.0?

  • @Nectar Are you using cmd or git bash?

  • @n.taddei
    I tried cmd, git bash, npm.cmd & node independently
    Problem was that npm install -g quasar-cli was not installing the quasar.cmd files in the .bin file of nodist(node/npm version control).
    I had to reinstall nodist (and node and npm) after an update.
    quasar.cmd was installed properly and am up & running.
    Mind you I’ve got to update a couple of node_modules now 😉

    Thanks for the feedback @s-molinari & @n-taddei - your remarks helped me figure it out.

  • With yarn add not work.
    With npm install work well.

  • i am trying to create new quasar project folder by using (quasar create <folder name > command ) but it is not working why

  • Please don’t use old threads for new problems. Start a new thread. Also, you need to explain more to get help. What did you do to the point of not getting further. Are you seeing any errors? If no errors, what do you see?


Log in to reply