Q-table height issue show all records without pagination



  • With QTable, I do not want pagination and just want a scroll bar with all records. I am only able to see a certain number of records in my widget with a scroll. Unless I activate pagination the rest of the records remain invisible. Am I missing something ? My QTable is inside QCarousel.

    <q-carousel v-model=“slide” transition-prev=“jump-right” transition-next=“jump-left” swipeable
    animated control-color=“black” navigation-icon=“radio_button_unchecked” navigation
    :fullscreen.sync=“fullscreen” infinite>
    <q-carousel-slide :name=‘index’ v-for="(tab, index) in dialog.dataObj" :key=“index”>
    <q-banner dense class=“text-center bg-info text-white”>{{tab.tabName}}</q-banner>
    <div class=“text-center”>
    <q-table dense :data=“tab.data” :columns=“tab.columns” row-key=“name”
    :pagination.sync=“pagination” class=“my-sticky-header-table”></q-table>
    </div>
    </q-carousel-slide>
    <template v-slot:control>
    <q-carousel-control position=“top-right” :offset="[18, 18]">
    <q-btn push round dense color=“white” text-color=“primary”
    :icon=“fullscreen ? ‘fullscreen_exit’ : ‘fullscreen’”
    @click=“fullscreen = !fullscreen” />
    </q-carousel-control>
    </template>
    </q-carousel>





  • @metalsadman Thanks a lot, it’s working. I was not setting pagination object when using hide-bottom attribute, thinking it won’t be needed.


Log in to reply