Unable to run dev mode cordova on mac

  • I’m on a Mac Os 10.14.6 with latest Xcode available

    When I try to run cordova dev I got what follows

    I already tried to remove platform from cordova and/or to remove mode from quasar, with any difference in results

    What am I doing wrong?

    quasar dev -m cordova -T ios
     Dev mode.......... cordova
     Pkg quasar........ v1.0.5
     Pkg @quasar/app... v1.0.4
     Debugging......... enabled
     app:extension Running "@quasar/icon-genie" Quasar App Extension... +0ms
     app:quasar-conf Reading quasar.conf.js +15ms
     app:external-ip Detected external IP and using it +7ms
     app:dev Checking listening address availability ( +0ms
     app:webpack Extending Cordova Webpack config +1s
     app:dev Extension(@quasar/icon-genie): Running beforeDev hook... +598ms
     app:generator Generating Webpack entry point +383ms
     app:dev-server Booting up... +6ms
     Cordova █████████████████████████ [100%] in ~14s
     DONE  Compiled successfully in 14130ms                                            10:18:15 PM
     app:cordova-conf Updated Cordova config.xml +15s
     app:spawn Running "cordova run ios --buildFlag=-UseModernBuildSystem=0" +1ms
    No simulator found for ". Falling back to the default target.
    Building for "iPhone Xʀ" Simulator (com.apple.CoreSimulator.SimDeviceType.iPhone-XR, iPhone-XR).
    Building project: /Users/realtebo/quasar_course_udemy/src-cordova/platforms/ios/Awesome Todo.xcworkspace
    	Configuration: Debug
    	Platform: emulator
    	Target: iPhone Xʀ
    Adding xcodebuildArg: -UseModernBuildSystem=0
    Running command: xcodebuild -workspace Awesome Todo.xcworkspace -scheme Awesome Todo -configuration Debug -sdk iphonesimulator -destination platform=iOS Simulator,name=iPhone Xʀ build CONFIGURATION_BUILD_DIR=/Users/realtebo/quasar_course_udemy/src-cordova/platforms/ios/build/emulator SHARED_PRECOMPS_DIR=/Users/realtebo/quasar_course_udemy/src-cordova/platforms/ios/build/sharedpch -UseModernBuildSystem=0
    User defaults from command line:
        UseModernBuildSystem = 0
    Build settings from command line:
        CONFIGURATION_BUILD_DIR = /Users/realtebo/quasar_course_udemy/src-cordova/platforms/ios/build/emulator
        SDKROOT = iphonesimulator12.4
        SHARED_PRECOMPS_DIR = /Users/realtebo/quasar_course_udemy/src-cordova/platforms/ios/build/sharedpch
    xcodebuild: error: Unable to find a destination matching the provided destination specifier:
    		{ platform:iOS Simulator, OS:latest, name:iPhone Xʀ }
    	The requested device could not be found because no available devices matched the request.
    	Available destinations for the "Awesome Todo" scheme:
    		{ platform:iOS Simulator, id:C9483BC5-F756-4D2C-AA6E-953FC882987B, OS:12.2, name:iPad (5th generation) }
    		{ platform:iOS Simulator, id:4723F693-252C-4D4F-B73A-9822EAAAD6BD, OS:12.2, name:iPad (6th generation) }
    		{ platform:iOS Simulator, id:1D9FA37E-F309-4555-9392-B9E0BAD60A54, OS:12.2, name:iPad Air }
    		{ platform:iOS Simulator, id:664A3CB1-8D37-4C3B-90AA-CC476A535CD9, OS:12.2, name:iPad Air (3rd generation) }
    		{ platform:iOS Simulator, id:C6F70F5F-42AF-4A06-8CA7-F5FB6A9E436A, OS:12.2, name:iPad Air 2 }
    		{ platform:iOS Simulator, id:DCCFC9B3-A687-49A2-970F-9605D64BA485, OS:12.2, name:iPad Pro (9.7-inch) }
    		{ platform:iOS Simulator, id:A2945744-4C1C-41D7-8A2C-6B4191ECD3AA, OS:12.2, name:iPad Pro (10.5-inch) }
    		{ platform:iOS Simulator, id:A8E5A550-E797-41C7-BF96-C53F09B9113E, OS:12.2, name:iPad Pro (11-inch) }
    		{ platform:iOS Simulator, id:CE49AB76-769C-4407-B6BB-7B750F8F16EE, OS:12.2, name:iPad Pro (12.9-inch) }
    		{ platform:iOS Simulator, id:2BDB416B-A91D-47A6-ABAC-6A7320C40403, OS:12.2, name:iPad Pro (12.9-inch) (2nd generation) }
    		{ platform:iOS Simulator, id:20550548-DA19-4749-9FB4-32D8706C8BAA, OS:12.2, name:iPad Pro (12.9-inch) (3rd generation) }
    		{ platform:iOS Simulator, id:6D8BDDF6-7B18-49EA-9C41-C66C18A20A4F, OS:12.2, name:iPhone 5s }
    		{ platform:iOS Simulator, id:F489FABA-D2CB-4A90-A26F-6C887FAF9EC4, OS:12.2, name:iPhone 6 }
    		{ platform:iOS Simulator, id:A7E30A6B-8408-483F-BCE9-2FC330A00315, OS:12.2, name:iPhone 6 Plus }
    		{ platform:iOS Simulator, id:33FAD07B-7556-4B71-B83C-E5C33AD26D70, OS:12.2, name:iPhone 6s }
    		{ platform:iOS Simulator, id:6BE5E7AA-EB94-428D-9CEA-538FB7F04235, OS:12.2, name:iPhone 6s Plus }
    		{ platform:iOS Simulator, id:AD65C887-19E8-4BA2-8345-4087BC0B6369, OS:12.2, name:iPhone 7 }
    		{ platform:iOS Simulator, id:EE6C5700-A299-4530-AD29-4D7B5F5E8739, OS:12.2, name:iPhone 7 Plus }
    		{ platform:iOS Simulator, id:642C26AA-F6DC-4FE5-96AA-670D502126EE, OS:12.2, name:iPhone 8 }
    		{ platform:iOS Simulator, id:F83DDB7E-11CB-45A7-8872-9995CFDB846D, OS:12.2, name:iPhone 8 Plus }
    		{ platform:iOS Simulator, id:AB504783-033C-4DAD-B6B2-C44F4FBA428A, OS:12.2, name:iPhone SE }
    		{ platform:iOS Simulator, id:279C8089-A90F-4B78-9F25-E5DD2484C798, OS:12.2, name:iPhone X }
    		{ platform:iOS Simulator, id:B401E8E2-4DF4-43DD-96F2-90F100C2C3DF, OS:12.2, name:iPhone Xs }
    		{ platform:iOS Simulator, id:5EFB2E9D-3E5F-4498-9F49-07196FCF3892, OS:12.2, name:iPhone Xs Max }
    		{ platform:iOS Simulator, id:51EB4DD4-CE11-4C38-9743-32492D10A767, OS:12.2, name:iPhone Xʀ }
    	Ineligible destinations for the "Awesome Todo" scheme:
    		{ platform:iOS, id:dvtdevice-DVTiPhonePlaceholder-iphoneos:placeholder, name:Generic iOS Device }
    		{ platform:iOS Simulator, id:dvtdevice-DVTiOSDeviceSimulatorPlaceholder-iphonesimulator:placeholder, name:Generic iOS Simulator Device }
    xcodebuild: Command failed with exit code 70
     app:spawn Command "cordova" failed with exit code: 70 +0ms
     app:cordova-conf Updated Cordova config.xml +3ms
     app:cordova-conf ⚠️  [FAIL] Cordova CLI has failed +0m

  • I tried to open Xcode, and verified that I’ve set iPhone xr as target and not “Generic Device”, that must be used only to make bundle for Apple Store.

    I also cleaned the build folder from Xcode.

    Restarted. same command, same output.

  • I tried to run the app directly from inside Xcode, but it fails with this cryptic error

    ios/Awesome Todo/Classes/MainViewController.xib:-1: 
    Failed to find or create execution context for description
     '<IBCocoaTouchPlatformToolDescription: 0x7fee3049b600> 
    System content for IBCocoaTouchFramework-NineOneAndLater 
    <IBScaleFactorDeviceTypeDescription: 0x7fee3041e8c0> 
    scaleFactor=2x'. These intermediate objects were non-nil: (

  • Googling I found this Stackoverflow question: https://stackoverflow.com/questions/36533720/failed-to-find-or-create-execution-context-for-description-ibcocoatouchplatform

    It suggested to kill all simulator services then clean the build and restart.

    $ sudo killall -9 com.apple.CoreSimulator.CoreSimulatorService
    $ quasar dev -m cordova -T ios

    It worked !

Log in to reply