Upgrade not working - I did uncheck the box



  • I’m running beta 17 of 1.0.0. I went to upgrade to 1.0.5 but I’m getting the error described on the upgrade documentation page.

    With the Add ‘node_modules/.bin’ from the project root to %PATH% then restart your code editor. box checked in my IDE (WebStorm), I can normally run quasar commands such as quasar dev. When that is the case and I run quasar upgrade, I get the quasar cli help showing. Upgrade is not listed among the command options.

    However, when I uncheck the Add ‘node_modules/.bin’ from the project root to %PATH% then restart your code editor. box in my IDE, I instead get an error which says quasar is not recognized as an internal or external command.

    I must be missing something totally obvious. I’m on windows 😞 using npm.



  • BTW, “@quasar/cli”: “^1.0.0-beta.4”



  • use yarn for local package npm for global packages. please check the upgrade guide, haven’t used in webstorm so better do it in your cmd or if you have git bash for windows. https://quasar.dev/start/upgrade-guide#Upgrading-from-0.x-to-v1



  • I ended up using npm. Thanks, though.


Log in to reply