Released quasar/app 1.0.4 -- security update


  • Admin

    Released quasar/app 1.0.4. Please upgrade to it ASAP — includes a security fix. https://github.com/quasarframework/quasar/releases/tag/%40quasar%2Fapp-v1.0.4



  • My upgrade failed with the following announcement
    npm ERR! Unexpected end of JSON input while parsing near ‘…2vz\n90WZJyQY+m/J4XoI’

    npm ERR! A complete log of this run can be found in:
    npm ERR! C:\Users\User\AppData\Roaming\npm-cache_logs\2019-07-11T18_02_17_623Z-debug.log

    Quasar CLI · ⚠️ Command “npm” failed with exit code: 1



  • Debug log:
    1626 verbose stack SyntaxError: Unexpected end of JSON input while parsing near ‘…2vz\n90WZJyQY+m/J4XoI’
    1626 verbose stack at JSON.parse (<anonymous>)
    1626 verbose stack at parseJson (C:\Users\User\AppData\Roaming\nvm\v8.15.0\node_modules\npm\node_modules\json-parse-better-errors\index.js:7:17)
    1626 verbose stack at consumeBody.call.then.buffer (C:\Users\User\AppData\Roaming\nvm\v8.15.0\node_modules\npm\node_modules\node-fetch-npm\src\body.js:96:50)
    1626 verbose stack at <anonymous>
    1626 verbose stack at process._tickCallback (internal/process/next_tick.js:189:7)
    1627 verbose cwd c:\Users\User\Documents\GitHub\dynafit
    1628 verbose Windows_NT 10.0.17763
    1629 verbose argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “install” “–save–dev” “@quasar/app@^1.0.4”
    1630 verbose node v8.15.0
    1631 verbose npm v6.4.1
    1632 error Unexpected end of JSON input while parsing near ‘…2vz\n90WZJyQY+m/J4XoI’
    1633 verbose exit [ 1, true ]



  • delete node_modules and your lock file and re-install



  • @Hawkeye64 Thanks!



  • @pytely I take it that set of instructions worked out for you then?



  • Yes! I’m now on version 1.0.4. Thank you


Log in to reply