[Solved] Quasar V1 "Failed to compile with X errors" but no error shown



  • Software version
    OS: mac os high sierra
    Node: 12.5.0
    NPM: 6.10.0
    yarn: 1.16.0

    $ quasar dev
    
     Dev mode.......... spa
     Pkg quasar........ v1.0.3
     Pkg @quasar/app... v1.0.2
     Debugging......... enabled
    
     app:quasar-conf Reading quasar.conf.js +0ms
     app:dev Checking listening address availability (0.0.0.0:8080)... +5ms
     app:webpack Extending SPA Webpack config +456ms
     app:generator Generating Webpack entry point +231ms
     app:dev-server Booting up... +5ms
    
    
     SPA █████████████████████████ [100%] in ~18s
    
    
    
     ERROR  Failed to compile with 2 errors   
    
    

    (that is ALL the output) 😞

    What were you expecting?
    A list of errors so that I can debug/fix them

    What steps did you take, to get the error?

    package.json :

      "private": true,
      "scripts": {
        "lint": "eslint --ext .js,.vue src",
        "test": "echo \"No test specified\" && exit 0"
      },
      "dependencies": {
        "@quasar/extras": "^1.0.0",
        "apollo-cache-inmemory": "^1.1.12",
        "apollo-client": "^2.2.8",
        "apollo-link": "^1.2.12",
        "apollo-link-context": "^1.0.18",
        "apollo-link-error": "^1.1.11",
        "apollo-link-http": "^1.5.15",
        "axios": "^0.19.0",
        "croppie": "^2.6.4",
        "firebase": "^6.2.4",
        "graphql": "^0.13.2",
        "graphql-tag": "^2.10.1",
        "moment": "^2.22.1",
        "moment-timezone": "^0.5.16",
        "quasar": "^1.0.0",
        "vue-apollo": "^3.0.0-rc.1",
        "vue-i18n": "^8.11.2",
        "vuelidate": "^0.7.4"
      },
      "devDependencies": {
        "@quasar/app": "^1.0.1",
        "@babel/core": "7.5.0",
        "@babel/plugin-transform-runtime": "7.5.0",
        "@babel/preset-env": "7.5.0",
        "@babel/preset-stage-2": "7.0.0",
        "@babel/runtime": "7.5.0",
        "@vue/eslint-config-standard": "^4.0.0",
        "babel-eslint": "^10.0.1",
        "eslint": "^5.10.0",
        "eslint-loader": "^2.1.1",
        "eslint-friendly-formatter": "^4.0.1",
        "eslint-config-standard": "^12.0.0",
        "eslint-plugin-import": "^2.18.0",
        "eslint-plugin-local-rules": "^0.1.0",
        "eslint-plugin-node": "^8.0.1",
        "eslint-plugin-promise": "^4.0.1",
        "eslint-plugin-standard": "^4.0.0",
        "eslint-plugin-vue": "^5.2.3",
        "node-sass": "^4.12.0",
        "sass-loader": "^7.1.0",
        "strip-ansi": "^3.0.1"
      },
      "engines": {
        "node": ">= 8.9.0",
        "npm": ">= 5.6.0"
      },
      "browserslist": [
        "> 1%",
        "last 2 versions",
        "not ie <= 10"
      ]
    }
    
    


  • It’s resolved, after the migration to version 1, I forgot to replace :

    import(quasar/lang/${locale}).then(lang => {
    })

    instead of

    import(quasar-framework/i18n/${locale}).then(lang => {
    })



  • Yes, would bne nice if we could get even more error information out of JS. Although, very once in a while, something comes along that makes life easier. 🙂


Log in to reply