Upgrading quasar breaks dev server



  • Hey guys, I was using quasar 1.0.0 beta 4. I just ran yarn upgrade and now I’m getting an error when I try to run quasar dev:

    ERROR Failed to compile with 1 errors 12:17:41 PM

    error in ./node_modules/quasar/dist/quasar.styl

    Module build failed (from ./node_modules/postcss-loader/src/index.js):
    BrowserslistError: Unknown browser query last 1 version, not dead, ie >= 11

    I can change the line in the quasar.styl file within the node_modules folder but this is, obviously, not ideal.
    Anyone have some insight?

    Thanks



  • my package.json if it helps:

    "dependencies": {
    	"@babel/polyfill": "^7.4.0",
    	"@babel/runtime": "^7.4.0",
    	"@bugsnag/js": "^6.0.0",
    	"@bugsnag/plugin-vue": "^6.0.0",
    	"@quasar/cli": "^1.0.0-beta.3",
    	"@quasar/extras": "^1.1.1",
    	"algoliasearch": "^3.32.0",
    	"algoliasearch-helper": "^2.26.0",
    	"avoriaz": "^6.3.0",
    	"aws-amplify": "^1.1.22",
    	"aws-amplify-vue": "^0.2.7",
    	"aws-sdk": "^2.420.0",
    	"axios": "^0.18.0",
    	"compression-webpack-plugin": "^1.1.12",
    	"cordova": "^9.0.0",
    	"country-list": "^1.1.1",
    	"instantsearch.js": "^2.10.4",
    	"lodash": "^4.17.11",
    	"moment": "^2.24.0",
    	"node-sass": "^4.11.0",
    	"quasar": "^1.0.0-beta.11",
    	"sass-loader": "^7.1.0",
    	"vue": "^2.6.10",
    	"vue-awesome-swiper": "^3.1.3",
    	"vue-confetti": "^1.1.3",
    	"vue-instantsearch": "^1.7.0",
    	"vue-radial-progress": "^0.2.10",
    	"vue-router": "^3.0.2",
    	"vue-scrollto": "^2.15.0",
    	"vuex-localstorage": "^1.0.0"
    },
    "devDependencies": {
    	"@babel/core": "^7.3.4",
    	"@babel/plugin-syntax-dynamic-import": "^7.2.0",
    	"@babel/plugin-transform-modules-commonjs": "^7.4.0",
    	"@babel/plugin-transform-runtime": "^7.3.4",
    	"@babel/preset-env": "^7.3.4",
    	"@quasar/app": "^1.0.0-beta.12",
    	"@quasar/quasar-app-extension-testing": "^1.0.0-rc.4",
    	"@quasar/quasar-app-extension-testing-e2e-webdriver": "^1.0.0-beta.6",
    	"@quasar/quasar-app-extension-testing-unit-jest": "^1.0.0-beta.18",
    	"@wdio/cli": "^5.7.5",
    	"@wdio/local-runner": "^5.7.5",
    	"@wdio/mocha-framework": "^5.7.3",
    	"@wdio/reporter": "^5.7.2",
    	"appium": "^1.12.0",
    	"autoprefixer": "^7.2.6",
    	"babel-core": "^7.0.0-bridge.0",
    	"babel-eslint": "^8.2.1",
    	"babel-helper-vue-jsx-merge-props": "^2.0.3",
    	"babel-jest": "^21.2.0",
    	"babel-loader": "^8.0.5",
    	"babel-plugin-dynamic-import-node": "^1.2.0",
    	"babel-plugin-module-resolver": "^3.2.0",
    	"babel-plugin-syntax-jsx": "^6.18.0",
    	"babel-plugin-transform-es2015-modules-commonjs": "^6.26.0",
    	"babel-plugin-transform-runtime": "^6.22.0",
    	"babel-plugin-transform-vue-jsx": "^3.5.1",
    	"babel-preset-env": "^1.6.0",
    	"babel-preset-es2015": "^6.24.1",
    	"babel-preset-stage-2": "^6.22.0",
    	"babel-preset-vue": "^2.0.2",
    	"babel-register": "^6.22.0",
    	"chai": "^4.2.0",
    	"chai-spies": "^1.0.0",
    	"chromedriver": "^2.46.0",
    	"css-loader": "^0.28.11",
    	"eslint": "^4.18.2",
    	"eslint-config-standard": "^11.0.0",
    	"eslint-friendly-formatter": "^3.0.0",
    	"eslint-loader": "^2.1.2",
    	"eslint-plugin-html": "^4.0.6",
    	"eslint-plugin-import": "^2.16.0",
    	"eslint-plugin-node": "^6.0.1",
    	"eslint-plugin-promise": "^3.7.0",
    	"eslint-plugin-standard": "^3.0.1",
    	"eslint-plugin-vue": "^4.3.0",
    	"expect": "^23.6.0",
    	"faker": "^4.1.0",
    	"jest": "^24.5.0",
    	"jest-vue-preprocessor": "^1.5.0",
    	"jsdom": "^11.12.0",
    	"jsdom-global": "^3.0.2",
    	"regenerator-runtime": "^0.11.0",
    	"sinon": "^6.3.5",
    	"strip-ansi": "^3.0.1",
    	"vue-jest": "^3.0.4",
    	"vue-loader": "^15.7.0",
    	"vue-style-loader": "^3.1.2",
    	"vue-svg-loader": "^0.12.0",
    	"vue-template-compiler": "^2.6.10",
    	"vue-test-utils": "^1.0.0-beta.11",
    	"wdio-appium-service": "^0.2.3",
    	"wdio-chromedriver-service": "^5.0.1"
    },
    "engines": {
    	"node": ">= 8.9.0",
    	"npm": ">= 5.6.0",
    	"yarn": ">= 1.6.0"
    },
    "browserslist": [
    	"> 1%",
    	"last 2 versions",
    	"not ie <= 10"
    ]


  • quasar upgrade -i



  • @metalsadman I get:
    Congrats! All Quasar packages are up to date. And the error persists…



  • jfc, finally figured it out after half a day…
    having “autoprefixer”: “^7.2.6” in my package json was bringing in an outdated version of browserslist. removing this fixed the issue.
    Hope this helps some one else!



  • just wondering are you using amplify and amplify-vue with federated signin? I can’t seems to get it work on my Quasar app



  • you are probably using @import '~quasar-variables' in a stylus file / template. This is no longer needed.


Log in to reply