Fix @Babel error after update from v1.0.0-beta22 to v1.0.0-rc4



  • Hope this helps someone

    What did you get as the error?

    Cannot find module '/app/node_modules/@quasar/babel-preset-app/node_modules/@babel/runtime/helpers/interopRequireDefault' from 'jest.setup.js'
    

    What were you expecting?

    tests to run as usual

    What steps did you take, to get the error?

    I updated quasar from version 1.0.0-beta.22 to quasar version 1.0.0-rc4

    Solution

    I then solved the issue by doing the following:

    cd node_modules/@quasar/babel-preset-app && yarn
    

    after that it runs as before. Reason being that the package wasn’t installed, I don’t know why, maybe it didn’t happen during upgrade process.


Log in to reply