Unable to migrate to v1



  • As the v1 seemed to be ready, and I saw a few components I would like to use there, I decided to upgrade my project but am stuck with errors everywhere…

    I had been using vue cli 3 without problems until now.

    My current package.json:

      "dependencies": {
        "@quasar/extras": "^1.1.2",
        "quasar": "^1.0.0-rc.3",
        "quasar-cli": "^0.17.25",
        "register-service-worker": "^1.5.2",
        "vue": "^2.5.22",
    ...
      "devDependencies": {
        "@quasar/app": "^1.0.0-rc.4",
        "vue-cli-plugin-quasar": "^0.17.1",
    

    I code in typescript btw, so in main.ts I had to change my
    import lang from 'quasar-framework/i18n/fr' into import lang from '../node_modules/quasar/lang/fr.js' because otherwise it wouldn’t find “quasar”. Same problem for other imports from “quasar”, yet it seems to work to import from “quasar-extras”. WTF?
    After hacking around like this the page displays something again but the style is completely broken, and components which used to work just fine don’t, with such warnings: Unknown custom element: <q-modal>. I followed the upgrade guide and probably fucked up somewhere, but to such an extent?



  • @Cochonours Qmodal is QDialog / q-dialog in v1.



  • Oh, that solves it. Also q-layout-header is just q-header now. Do you know why my imports are broken though? I shouldn’t have to relatively specify the path…

    And also, the style is KO. I get no errors so I’m not sure how to solve the mess… Even my router-link’s are unclickable. <= nevermind that, I found the culprit.



  • I suggest you follow the upgrade guide https://quasar.dev/start/upgrade-guide if you haven’t yet.



  • That’s what I followed…


Log in to reply