Error Module not found : babel-loader / vue-loader



  • I have a problem with my project, when it is built locally it works fine, but when it is built on the server there is an error message like this

    ERROR in ./src/pages/login/P_Login.vue?vue&type=script&lang=js& (./node_modules/babel-loader/lib??ref--1-0!./node_modules/vue-loader/lib??vue-loader-options!./src/pages/login/P_Login.vue?vue&type=script&lang=js&)
    Module not found: Error: Can't resolve '../../components/login/C_login.vue' in '/my_web/src/pages/login'
     @ ./src/pages/login/P_Login.vue?vue&type=script&lang=js& (./node_modules/babel-loader/lib??ref--1-0!./node_modules/vue-loader/lib??vue-loader-options!./src/pages/login/P_Login.vue?vue&type=script&lang=js&) 2:0-56 7:12-18
     @ ./src/pages/login/P_Login.vue?vue&type=script&lang=js&
     @ ./src/pages/login/P_Login.vue
     @ ./src/router/routes.js
     @ ./src/router/index.js
     @ ./.quasar/app.js
     @ ./.quasar/client-entry.js
     @ multi ./.quasar/client-entry.js
    

    I’ve also tried running “npm i vue-loader” and “npm i babel-loader” still doesn’t solve the problem

    maybe someone can help me to solve my problem, I have used Quasar a little, but I don’t know much about webpack.

    thanks.



  • I’d say it has nothing to do with webpack directly. For some reason the C_login.vue file can’t be found. Are you sure it is uploaded to the server? Is the path correct?

    Scott



  • @s-molinari

    the file is available on the server
    and the project works well when built locally

    Screen Shot 2019-05-27 at 16.26.23.png
    Screen Shot 2019-05-27 at 16.26.11.png



  • Hmm…Have a look at the file being called for and the actual file. Capitalization does make a difference. 😄

    Scott



  • wow 🤣 🤣 🤣 , thank you the problem has been resolved, i just learned to use quasars, thank you for your help


  • Admin

    FYI: Do NOT manually install babel-loader, vue-loader, vue, vue-router, webpack. These are supplied by @quasar/app after careful testing. If you install them manually then the warranty on Quasar is off.


Log in to reply