@quasar/app 1.0.0-rc.4 released!


  • Admin

    https://github.com/quasarframework/quasar/releases/tag/%40quasar%2Fapp-v1.0.0-rc.4

    • Forcing babel core-js to v2 (recommended; no need to change your current babel.conf.js)
    • ONLY if you really need core-js v3 (at this moment highly unrecommended), then the optional way to configure it is:
      module.exports = {
        presets: [
          [
            '@quasar/babel-preset-app', {
              presetEnv: { corejs: 3 }
            }
          ]
        ]
      }
      


  • I upgraded and the preset is included in my babel.config.js . When running dev script on my app I get:

    > Executing task: npm run dev <
    
    
    > Myapp@0.0.1 dev /home/usr/myproject
    > quasar dev
    
    
     Dev mode.......... spa
     Pkg quasar........ v1.0.0-rc.2
     Pkg @quasar/app... v1.0.0-rc.4
     Debugging......... enabled
    
     app:quasar-conf Reading quasar.conf.js +0ms
     app:dev Checking listening address availability (0.0.0.0:8080)... +4ms
    (node:25416) UnhandledPromiseRejectionWarning:   TypeError: Cannot destructure property `createHash` of 'undefined' or 'null'.
      
      - index.js:25 Object.<anonymous>
        [y1]/[mini-css-extract-plugin]/dist/index.js:25:5
      
      - module.js:11 require
        internal/module.js:11:18
      
      - cjs.js:3 Object.<anonymous>
        [y1]/[mini-css-extract-plugin]/dist/cjs.js:3:18
      
    
    (node:25416) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 2)
    (node:25416) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
    

  • Admin

    @MusicForMellons are you using the unrecommended core-js v3? Leave your babel.config.js as it was.



  • Yeah, I am on core-js 2 now and it works. Thanks!


Log in to reply