[v1] Quasar v1.0.0-beta.17 released!

  • Admin

    [v1] Quasar v1.0.0-beta.17 released! Important fixes for QSelect and many more. https://github.com/quasarframework/quasar/releases/tag/quasar-v1.0.0-beta.17

    • fix(QMenu/QTooltip): fix issue with scroll bar positioning (fix #3284) (#3854)
    • fix(QSelect): Condition for showing Dialog
    • fix(QSelect): [v1] QSelect scroll jumps up when the mouse is moved #3848
    • fix+perf(QSelect): [v1] QSelect Autocomplete on more than 2 chars example not working properly #3850
    • fix(lang-fr): Add a space before the colon and addition typos (#3847)
    • fix(quasar): Further fix on QBtn double click on form submit, disabled :to, cleanups (#3856)
    • fix(quasar): Guard date.formatDate for Infinity/-Infinity and invalid dates (#3855)
    • fix(ie): Some tweaks on QSpinner (#3864)
    • refactor(QBreadcrumbs): QBreadcrumbs “artifacts” #3872
    • feat(QInput): improve autofill color (and add $input-autofill-color) #3860
    • fix(QDrawer): [V1] QDrawer loses backdrop color when opening below the breakpoint and widening the window above it #3861
    • feat(QInput/QSelect/QField): Do not disable before/after/hint/error slot when “disable” or “readonly” props are used
    • fix(api): Update QSeparator.json (#3884)
    • fix(QSlider/QRange): [V1] QSlider long label display error #3887
    • fix(LocalStorage/SessionStorage): LocalStorage problem when cookies are disabled #3888

  • getting error issuing quasar upgrade -i or npm install --save @quasar/cli@latest.

    error Unexpected end of JSON input while parsing near '...12"}},"2.1.0-beta.27"'

    Edit: Nvm, I installed yarn and it’s working now.

  • Can’t compile anymore. Nothing else changed, just upgraded, also removed all extension.

  • @kp did you tried yarn instead? since i read in their discord that npm does not work properly on windows so yeah, just tried yarn and it worked for me with this upgrade.

  • So if I understand correctly, this is just a windows things? I can continue using npm on linux?

  • Admin

    @DevinH You can, but a headaches-free environment would be to use yarn, regardless of OS.

Log in to reply