AdMob stuck on testAd

  • Hi all,

    I have a problem with AdMobs, not sure where issue lies, Could be banner settings on google, cordova plugin or quasar. Starting with quasar maybe config or env vars solution…

    I can see test ads no problem, but only test ads. When running cordova run or with signed/unsigned builds on my smartphone - its always got test Ad on it. Displayed like a title on top center of banner. I’ve removed the isTesting param, set it to false an tried any numerous add removing the following:

        document.addEventListener('deviceready', ()=>{
          console.log('admobid: ', admobid)
          console.log('Device is ready')
          if(AdMob) setTimeout(()=>{AdMob.createBanner({ // put top of event stack
            // adSize: 'SMART_BANNER',
            // width: 360, // valid when set adSize 'CUSTOM'
            // height: 90, // valid when set adSize 'CUSTOM'
            position: AdMob.AD_POSITION.BOTTOM_CENTER,
            // x: 0,		// valid when set position to POS_XY
            // y: 0,		// valid when set position to POS_XY
            adId: admobid.banner,
            isTesting: false,
            overlap: true,
            autoShow: true,
          else console.error('AdMob not created :(')

    Always resulting in testAd, can’t find anything in google or cordova plugin either:

        <plugin name="cordova-plugin-admobpro" spec="^2.37.2">
            <variable name="PLAY_SERVICES_VERSION" value="16.0.0" />

    any help appreciated

  • Hi, did you figure that out ? I am having same problem. Not sure if it has to be published in play store for ads ?

  • I
    have the same problem, someone solved it?

Log in to reply