ClosePopup Error in beta 1.0.0



  • Hi,

    Beginner dev here. Running a vanilla Quasar SSR project. I’m trying to add v-close-popup to a dialogue button, but I can’t even get that far. The minute I add the ‘ClosePopup’ directive to the directives list in quasar.conf.js (as below):

      directives: [
        'ClosePopup',
        'Ripple'
      ],
    

    …running quasar dev -m ssr in the CLI will throw up an error (as below):

    Module build failed (from ./node_modules/babel-loader/lib/index.js):
    Error: Unknown import from Quasar: ClosePopup

    Remove the single ‘ClosePopup’ directive, and the app runs fine.

    Not sure if this is a bug or my inexperience showing in failing to catch a silly mistake. Any help appreciated.

    PS: confirmed I still get the same error running dev mode as SPA



  • Should note: using the Quasar CLI.



  • Same here. Please advice



  • Run “quasar info” to check your quasar version


  • Admin

    v-close-popup was added in quasar v1.0.0-beta.11.
    While we are in v1 beta, it is paramount that you are running latest version as soon as it is released.



  • @rstoenescu said in ClosePopup Error in beta 1.0.0:

    v-close-popup was added in quasar v1.0.0-beta.11.
    While we are in v1 beta, it is paramount that you are running latest version as soon as it is released.

    Turns out it was a silly mistake; this is exactly what was going on. Was on an earlier beta version. Thanks!