[V1.0] Vue packages version mismatch



  • I recently ran into an issue where my computer froze and after rebooting I had the following error

     error  in ./src/layouts/MyLayout.vue
    
    Module Error (from ./node_modules/vue-loader/lib/index.js):
    
    
    Vue packages version mismatch:
    
    - vue@2.6.8
    - vue-template-compiler@2.6.7
    
    This may cause things to work incorrectly. Make sure to use the same version for both.
    If you are using vue-loader@>=10.0, simply update vue-template-compiler.
    If you are using vue-loader@<10.0 or vueify, re-installing vue-loader/vueify should bump vue-template-compiler to the latest.
    
    
     @ ./src/router/routes.js 4:11-41
     @ ./src/router/index.js
     @ ./.quasar/app.js
     @ ./.quasar/client-entry.js
     @ multi (webpack)-dev-server/client?http://0.0.0.0:8080 (webpack)/hot/dev-server.js ./.quasar/client-entry.js
    

    I fixed it by running:

    yarn add vue-template-compiler
    

    I’m not sure how it came about but I’m adding the post in case anyone else runs into this issue