Unable to run quasar dev



  • Hi all,

    A co-worker of mine is having trouble running quasar dev in his project, encountering the following error:

    ERROR  Failed to compile with 1 errors                                                                                                                                                           10:52:29
    
    error  in ./.quasar/app.styl
    
    Module build failed:   Error: /Users/path/to/project/.quasar/app.styl:15:9
        11| // Then we load Quasar stylus files
        12| @import '~quasar-styl'
        13|
        14| // We add Quasar addons, if they were requested
        15| @import '~quasar-addon-styl'
     ---------------^
        16|
     failed to locate @import file ~quasar-addon-styl.styl
    
     - evaluator.js:157 CachedPathEvaluator.visitImport
       [narrative-v2]/[stylus-loader]/lib/evaluator.js:157:21
    
     - index.js:28 CachedPathEvaluator.Visitor.visit
       [narrative-v2]/[stylus]/lib/visitor/index.js:28:40
    
     - evaluator.js:160 CachedPathEvaluator.Evaluator.visit
       [narrative-v2]/[stylus]/lib/visitor/evaluator.js:160:18
    
     - evaluator.js:707 CachedPathEvaluator.Evaluator.visitRoot
       [narrative-v2]/[stylus]/lib/visitor/evaluator.js:707:27
    
     - index.js:28 CachedPathEvaluator.Visitor.visit
       [narrative-v2]/[stylus]/lib/visitor/index.js:28:40
    
     - evaluator.js:160 CachedPathEvaluator.Evaluator.visit
       [narrative-v2]/[stylus]/lib/visitor/evaluator.js:160:18
    
     - evaluator.js:247 CachedPathEvaluator.Evaluator.evaluate
       [narrative-v2]/[stylus]/lib/visitor/evaluator.js:247:15
    
     - renderer.js:86 Renderer.render
       [narrative-v2]/[stylus]/lib/renderer.js:86:26
    
     - index.js:167
       [narrative-v2]/[stylus-loader]/index.js:167:12
    
     - makePromise.js:840 tryCatchReject
       [narrative-v2]/[when]/lib/makePromise.js:840:30
    
     - makePromise.js:799 runContinuation1
       [narrative-v2]/[when]/lib/makePromise.js:799:4
    
     - makePromise.js:590 Fulfilled.when
       [narrative-v2]/[when]/lib/makePromise.js:590:4
    
     - makePromise.js:481 Pending.run
       [narrative-v2]/[when]/lib/makePromise.js:481:13
    
     - Scheduler.js:62 Scheduler._drain
       [narrative-v2]/[when]/lib/Scheduler.js:62:19
    
     - Scheduler.js:27 Scheduler.drain
       [narrative-v2]/[when]/lib/Scheduler.js:27:9
    
     - next_tick.js:112 process._tickCallback
       internal/process/next_tick.js:112:11
    
    
    
    @ ./.quasar/app.styl 4:14-189 13:3-17:5 14:22-197
    @ ./.quasar/entry.js
    @ multi ./node_modules/webpack-dev-server/client?http://0.0.0.0:8089 webpack/hot/dev-server ./.quasar/entry.js
    

    Things we’ve tried:

    • Upgrading npm, removing node_modules, getting the package lock file from a co-worker with a working project, and reinstalling node modules
    • Comparing the files in question with another co-worker

    The local quasar cli version in this project is 0.15.20. I hesitate to upgrade because that version is specified in the package lock and is working for other people. This issue started when he introduced Vuelidator to his project, but he reset his branch after to try and fix it.

    I don’t understand the framework well enough to help so I appreciate any input.

    Thanks.



  • Actually we just fixed it. Of all things, we had to delete the .quasar folder and let it regenerate when running quasar dev.

    I don’t know what could have affected the files there, but if anyone runs into this issue give it a shot.


Log in to reply