Internet Explorer 11 - missing chunk



  • Our Quasar app works perfectly on all browsers (Chrome, Safari, Firefox, Edge), except for IE11. I get an error indicating that a chunk cannot be loaded, it’s missing. Any help/tips would be greatly appreciated.

    Quasar info:

    Operating System Darwin(17.7.0) - darwin/x64
    NodeJs 8.9.4

    Global packages
    NPM 5.6.0
    yarn Not installed
    quasar-cli 0.17.22
    vue-cli 2.9.6
    cordova Not installed

    Important local packages
    quasar-cli 0.17.22 (Quasar Framework CLI)
    quasar-framework 0.17.18 (Build responsive SPA, SSR, PWA, Hybrid Mobile Apps and Electron apps, all simultaneously using the same codebase)
    quasar-extras 2.0.9 (Quasar Framework fonts, icons and animations)
    vue 2.5.17 (Reactive, component-oriented view layer for modern web interfaces.)
    vue-router 3.0.1 (Official router for Vue.js 2)
    vuex 3.0.1 (state management for Vue.js)
    electron Not installed
    electron-packager Not installed
    electron-builder Not installed
    @babel/core 7.0.0-beta.54 (Babel compiler core.)
    webpack 4.25.1 (Packs CommonJs/AMD modules for the browser. Allows to split your codebase into multiple bundles, which can be loaded on demand. Support loaders to preprocess files, i.e. json, jsx, es7, css, less, … and your custom stuff.)
    webpack-dev-server 3.1.10 (Serves a webpack app. Updates the browser on changes.)
    workbox-webpack-plugin 3.6.3 (A plugin for your Webpack build process, helping you generate a manifest of local files that workbox-sw should precache.)
    register-service-worker 1.5.2 (Script for registering service worker, with hooks)

    supportIE = true in quasar.conf.js

    devDependencies in package.json:

    “devDependencies”: {
    “babel-eslint”: “10.0.1”,
    “eslint”: “^5.9.0”,
    “eslint-config-standard”: “12.0.0”,
    “eslint-friendly-formatter”: “^4.0.1”,
    “eslint-loader”: “^2.1.1”,
    “eslint-plugin-import”: “^2.14.0”,
    “eslint-plugin-node”: “8.0.0”,
    “eslint-plugin-promise”: “4.0.1”,
    “eslint-plugin-standard”: “4.0.0”,
    “eslint-plugin-vue”: “^4.7.1”,
    “quasar-cli”: “^0.17.22”,
    “strip-ansi”: “^3.0.1”,
    “webpack-auto-inject-version”: “1.2.2”
    },

    Thanks, Jeff.



  • I’m also getting an occasional syntax error: vendor.ff7cbdea.js (55,64476)


  • Admin

    Are you sure you are using quasar.conf > build > transpileDependencies to add your deps that need ES6 transpiling? https://quasar-framework.org/guide/app-quasar.conf.js.html#build-Property



  • @rstoenescu - I added transpileDependencies to my quasar.conf > build with two dependencies that I discovered need transpiling (vuex-persist and vue-echarts-v3) and it solved my problem.

    You will be receiving a request for an invoice for us - it’s beyond time for us to begin supporting Quaser and rewarding your remarkable efforts! Thank you sir, it’s very much appreciated.


  • Admin

    @jeffatpf Thank you! Financial support is much needed. Feel free to connect with me by email.