Can't run "quasar dev" cause Quasar version is under v0.15



  • Hi, I can’t execute “quasar dev” in my project folder. It’s a fresh project.

    What I did:
    vue create myproject
    cd myproject
    vue add quasar
    npm i -g quasar-cli

    vue-cli version 3.0.3
    quasar-cli version 0.17.20

    package.json

      "dependencies": {
        "quasar-extras": "^2.0.4",
        "quasar-framework": "^0.17.0",
        "register-service-worker": "^1.0.0",
        "vue": "^2.5.17",
        "vue-class-component": "^6.0.0",
        "vue-property-decorator": "^7.0.0",
        "vue-router": "^3.0.1",
        "vuex": "^3.0.1"
      },
      "devDependencies": {
        "@types/chai": "^4.1.0",
        "@types/mocha": "^5.2.4",
        "@vue/cli-plugin-babel": "^3.0.5",
        "@vue/cli-plugin-e2e-nightwatch": "^3.0.5",
        "@vue/cli-plugin-pwa": "^3.0.5",
        "@vue/cli-plugin-typescript": "^3.0.5",
        "@vue/cli-plugin-unit-mocha": "^3.0.5",
        "@vue/cli-service": "^3.0.5",
        "@vue/test-utils": "^1.0.0-beta.20",
        "babel-plugin-transform-imports": "1.5.0",
        "chai": "^4.1.2",
        "lint-staged": "^7.2.2",
        "node-sass": "^4.9.0",
        "quasar-cli": "^0.17.20",
        "sass-loader": "^7.0.1",
        "stylus": "^0.54.5",
        "stylus-loader": "^3.0.2",
        "typescript": "^3.0.0",
        "vue-cli-plugin-quasar": "^0.17.1",
        "vue-template-compiler": "^2.5.17"
      },`
    

    Error when I execute quasar dev inside my project folder:

    app:paths ⚠️ Error. This command must be executed inside a Quasar v0.15+ project folder. +0ms
    app:paths For Quasar pre v0.15 projects, npm uninstall -g quasar-cli; npm i -g quasar-cli@0.6.5 +3ms

    Dunno why it says I’m under v0.15 …

    Thanks for any help



  • You can’t use Vue CLI and add Quasar as a plugin to Vue and expect the Quasar CLI to work. You need to use the Vue CLI only (i.e. with yarn serve or npm run serve).

    If you want to use the Quasar CLI, you need to init your project with the Quasar CLI only. Then your new project will work with quasar dev.

    Scott