Directory Doesn't Appear in Build



  • I’m working on an app that uses config files to perform some actions in the app. One part includes giving a path to where certain files are in the app. Our app then uses require(path) to read those files. However it appears that the files are not being added to the build so I can’t load them in our app.

    The following image shows the directory I added called device-elements in the src dir. When we initialize the app we pass in a config file to provide options to the app. The "elementsFile:path" tells the app where to find the 3 files in that new directory. We load it using require(elementsFile) so we can load those files.
    0_1539009895246_Config.png

    However the following 2 screenshots show that the device-elements directory I created does not appear to be in the app at all.
    0_1539010154833_App.png
    0_1539010354911_App2.png

    Any ideas on why the directory I created isn’t in the app and how I can resolve it so I can get our app up and running?



  • I have tried placing the device-elements directory in the assets directory as well with the same result. I also tried with it in statics and set the path to statics/device-elements so it ran require("statics/device-elements") and it couldn’t load it there. I also tried to create a plugin and I’m still playing with it but I don’t think a plugin will help us in our current situation. Any thoughts on how to get a directory to show up in the app?



  • This post is deleted!


  • I also tried adding a blank vue file to the src/pages directory and even that didn’t show up in the app’s source when running the app. What am I missing? This should be something that just works. Its a basic app created by running quasar init app-name. I haven’t added anything extra beyond that except a few lines of code in the Index.vue file to test some things. Do I have to add something to the config file to get it to recognize other files and directories which are added after creating the app?



  • you can debug in dev directory, and rebuild it in production. https://quasar-framework.org/guide/app-build-commands.html