Error running on Android: webpage at ip:port could not be loaded because net::ERR_ADDRESS_UNREACHABLE.



  • I am learning quasar and I created a new project using quasar init name. I then move into the new project root directory and ran quasar mode -a cordova to add a cordova project. I cd to src-cordova and run cordova platform add android and cordova requirements. No errors on the requirements check. I go back to the project root and run quasar dev -m cordova -T android. Its results in a empty page that says "webpage at ip:port could not be loaded because net::ERR_ADDRESS_UNREACHABLE. Running quasar dev works fine and quasar dev -m electron works as well. What am I missing to get this working on Android?



  • Quasar version 0.17.17, node version 8.9.4 and cordova 8.0.0.



  • I have updated and tried again and still the same problem. Quasar version 0.17.18, node version 8.12.0, cordova version 8.0.0 and npm 6.4.1. Are there any know problems between certain versions of these or other modules? Or maybe am I missing a step somewhere? Any ideas will be helpful.



  • This occurs with me too



  • I just tried on ios and I get just a blank page.

    Also if I cd to the src-cordova directory and run cordova run ios or cordova run android I get the starter cordova project.

    So what options should I have for IP addresses when I run quasar dev -m cordova -T android/ios? I’m getting 10.1.2.150 and 169.254.112.9 to choose from. On Android if I choose the first IP I get this error but the app crashes for not finding assets if I choose the 2nd IP. On iOS I get the same issue, blank screen, no matter which IP I choose. However a co-worker has 192.168.0.4 and 169.254.230.96. Our first IP’s are not even close to matching. Based on what my co-worker has I would think my choices should be 192.168.x.x or 169.254.x.x.

    @Luiz I just got word from someone on their discord that the development computer your working on must be on the same network or somehow pingable from your dev computer. My computer was not on the same network so i joined the network but I still cant ping my phone/tablet so I’m going investigate why. I’m guessing this will fix this issue.



  • This post is deleted!


  • This post is deleted!


  • This post is deleted!


  • your mobile phone should also be on the same network as your dev computer, also check the firewall of your dev computer.