[solved]Problem with q-step & data binding



  • I am creating a quiz wizard with q-step, v-for loop and q-inputs. Let’s say user choose 3 questions, it goes into a loop for each and creates its respectively step. When going to the step of the first question it works perfectly; when going to step of second question it apparently works perfectly; but when going to third question’ step, if i go back to question #2’ step data is no longer in its respectively field, nevertheless when I console log the array of the containing data the inserted data is there, correctly inserted, just that the q-input fields don’t load them. Even tho if i go to step #1 THE DATA DO CORRECTLY LOAD IN EACH FIELD :|

    You can give a try here: https://jsfiddle.net/leoprada/dbjoLpy1/6/

    Am i missing something? 😞 Please help



  • I found a solution for myself, while i was reading about setters i did a try on smt that read on internet, and definded the v-model=“foo” to the stepper tag, it’s not required but decided to use it and it solved the problem.